nifi-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Gough (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (NIFIREG-286) Upgrade dependencies
Date Tue, 30 Jul 2019 14:12:00 GMT

    [ https://issues.apache.org/jira/browse/NIFIREG-286?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16896170#comment-16896170
] 

Nathan Gough commented on NIFIREG-286:
--------------------------------------

Scott's PR will change a lot of the frontend lib versions: [https://github.com/apache/nifi-registry/pull/209],
so I'll hold off on upgrading these for now. A lot of the originally mentioned dep issues
like lodash, cryptiles etc were found in the package-json.lock as transitive dependencies,
so they may be upgraded as a result of Scott's change.

> Upgrade dependencies
> --------------------
>
>                 Key: NIFIREG-286
>                 URL: https://issues.apache.org/jira/browse/NIFIREG-286
>             Project: NiFi Registry
>          Issue Type: Improvement
>            Reporter: Nathan Gough
>            Priority: Major
>              Labels: dependencies, dependency, upgrade
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> Upgrade the following dependencies:
> |[fstream|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/fstream/open]|
> |[tar|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/tar/open]|
> |[jquery|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/jquery/open]|
> |[tar-fs|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/tar-fs/open]|
> |[com.puppycrawl.tools:checkstyle|https://github.com/apache/nifi-registry/network/alert/pom.xml/com.puppycrawl.tools:checkstyle/open]|
> |[lodash|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/lodash/open]|
> |[extend|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/extend/open]|
> |[deep-extend|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/deep-extend/open]|
> |[cryptiles|https://github.com/apache/nifi-registry/network/alert/nifi-registry-web-ui/src/main/frontend/package-lock.json/cryptiles/open]|



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message