nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy LoPresto <alopre...@apache.org>
Subject Re: asciidoctor-maven-plugin error on windows
Date Fri, 12 Jun 2020 00:47:17 GMT
Vasily,

This is not a known issue, as every PR runs a Windows Java 8 build which includes this step.
If you do file a Jira, please provide details on your Maven version & configuration, OS
version, full output of logs & errors, etc. 

Andy LoPresto
alopresto@apache.org
alopresto.apache@gmail.com
He/Him
PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69

> On Jun 11, 2020, at 5:16 AM, Vasily Makarov <vasily.makarov@ultratendency.com>
wrote:
> 
> Hi all!
> When building NiFi on windows I encounter such an error with asciidoctor-maven-plugin:
> 
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time:  01:22 min (Wall Clock)
> [INFO] Finished at: 2020-06-11T13:42:20+03:00
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.asciidoctor:asciidoctor-maven-plugin:1.5.2:process-asciidoc
(output-html) on project nifi-docs: Execution output-html of goal org.asciidoctor:asciidoctor-maven-plugin:1.5.2:process-asciidoc
failed: (LoadError) no such file to load -- asciidoctor -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the command
> [ERROR]   mvn <args> -rf :nifi-docs
> 
> 
> 
> I have temporarily resolved this issue by commenting out these rows in nifi-docs pom.xml:
> 
> 
> <!--                <executions>-->
> <!--                    <execution>-->
> <!--                        <id>output-html</id>-->
> <!--                        <phase>prepare-package</phase>-->
> <!--                        <goals>-->
> <!--                            <goal>process-asciidoc</goal>-->
> <!--                        </goals>-->
> <!--                    </execution>-->
> <!--                </executions>-->
> 
> Building with Java 1.8.0_211-b12, but I also have tried with newer versions of Java.
Is it a known issue or should I create an issue in Jira?


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message