nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Burgess <mattyb...@apache.org>
Subject Re: Upgrade to Avro 1.9.X
Date Tue, 24 Mar 2020 17:37:36 GMT
I've found one issue so far, nifi-avro-record-utils brings in an old
Jackson Databind transitively, most other modules that use Databind
use the same version (specified in the top-level POM). We'd have to
add a dependency there to force the upgrade of Databind, and change
the package of the ObjectMapper class to what it is in Databind 2.x. I
can't find any other reference to the old Databind (or its
ObjectMapper) yet, but still on the case :)

On Tue, Mar 24, 2020 at 1:25 PM Matt Burgess <mattyb149@apache.org> wrote:
>
> Looking at the Jiras that were released between 1.8.1 (our current
> version) and 1.9.2 (the current GA version of Avro) [1], it appears
> that if we were to upgrade Avro, we definitely should go to the latest
> (there are a number of regressions in 1.8.2 and 1.9.0 for example).
> However I'm a little leery of [2], it shouldn't affect anything we do
> inside NiFi, but I wonder if it's a dealbreaker for upgrade. What are
> your thoughts?  For reference, [3] is the list of open issues against
> 1.9.2 specifically, of course there may be some that are to be fixed
> in 1.9.3 but there aren't any yet with 1.9.3 set as a fix version, and
> I'm not a member of the Avro community so I don't know when/if 1.9.3
> will be released (or if [2] will be in it).
>
> I also haven't tried just upgrading on my local branch and running all
> tests, will do that shortly.
>
> Thanks,
> Matt
>
> [1] https://issues.apache.org/jira/browse/AVRO-1861?jql=project%20%3D%20AVRO%20AND%20fixVersion%20in%20(1.8.2%2C%201.9.0%2C%201.9.1%2C%201.9.2)%20AND%20component%20%3D%20java%20ORDER%20BY%20created%20DESC
> [2] https://issues.apache.org/jira/browse/AVRO-2742
> [3] https://issues.apache.org/jira/browse/AVRO-2742?jql=project%20%3D%20AVRO%20AND%20affectedVersion%20%3D%201.9.2%20AND%20component%20%3D%20java%20ORDER%20BY%20created%20DESC
>
> On Tue, Mar 24, 2020 at 10:13 AM Chad Zobrisky <czobrisky@gmail.com> wrote:
> >
> > Mike,
> >
> > I've been looking at this upgrade for a while since a bug in 1.8.x I ran
> > into with a JSON NULL error[1]. Wasn't sure how to proceed since quite a
> > few nars have dependencies on the avro and wasn't sure if they should be
> > upgrade together or not. Would love to work with you on this if possible.
> >
> > 1. https://issues.apache.org/jira/browse/AVRO-1954
> >
> > Chad
> >
> > On Tue, Mar 24, 2020 at 9:59 AM Mike Thomsen <mikerthomsen@gmail.com> wrote:
> >
> > > Are there any blockers here that would prevent us from upgrading and
> > > including the new UUID logical type in the record api?
> > >
> > > https://avro.apache.org/docs/1.9.2/spec.html#UUID
> > >

Mime
View raw message