nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Thomsen <mikerthom...@gmail.com>
Subject Re: Unable to update processor...
Date Tue, 14 Jan 2020 13:26:33 GMT
> I have copied my NAR file to /1.10.0/custom-lib/

If this was a NiFi 0.X thing, it's been deprecated in 1.X. The only folders
that NiFi reads from by default for custom extensions are *lib* and
*extensions*.

On Mon, Jan 13, 2020 at 4:47 PM Otto Fowler <ottobackwards@gmail.com> wrote:

> you want to look at the nifi app log and bootstrap logs at startup.
>
> Nifi discovers, unpacks and the loads the NARS at startup. If you aren’t
> seeing your custom processor there then that process, that is in the logs
> will show what is going on.
>
>
>
>
> On January 13, 2020 at 16:44:36, Russell Bateman (russ@windofkeltia.com)
> wrote:
>
> I have a custom processor that I have updated (in potentially breaking
> ways and I know it), but I cannot seem to make NiFi 1.10.0 open its
> mouth and swallow it. I have copied my NAR file to /1.10.0/custom-lib/;
> there is no other version (in the /lib/ subdirectory for example). When
> I bounce NiFi I see nothing of the changes (properties wording, etc.).
> I've been away from NiFi for a while; maybe I'm forgetting something. I
> found some artifacts in /1.10.0/work/nar/extensions/ and
> /1.10.0/work/docs/ which I removed before bouncing NiFi, but when it
> comes back up, all that stuff appears to have been brought back. What am
> I missing? Any suggestions of where to look would be welcome.
>
> Thanks,
> Russ
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message