nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Witt <joe.w...@gmail.com>
Subject Re: Provenance query does not show results
Date Mon, 16 Sep 2019 15:31:40 GMT
Mark

I believe I've seen this as well - or I'm confusing issues - but as I
recall it had to do with settings for shard size/retention size not making
sense.  As an admin configuring it though you cannot really see/reason over
this and I dont think we log anything about it (could be mistaken).  This
definitely needs to be improved so that if bad settings are used then the
user is warned and possibly startup is cancelled.

Thanks

On Mon, Sep 16, 2019 at 11:25 AM Mark Bean <mark.o.bean@gmail.com> wrote:

> There have been several times on different NiFi instances where the
> Provenance Query results are not shown. It appears as if there are no
> provenance events at all. However, after restarting NiFi, the events
> correctly appear.
>
> This has been observed in 1.8.0 and 1.9.2. There is a JIRA ticket [1] which
> may be indicating the same issue in 1.7.1. It is still open.
>
> I have only observed the problem, but not dug too deeply to diagnose yet. I
> was only able to identify the provenance repo as the
> WriteAheadProvenanceRepository.
>
> I am curious if anyone has experienced similar behavior?
>
> [1] https://issues.apache.org/jira/browse/NIFI-5804
>
> Thanks,
> Mark
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message