nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy LoPresto <alopre...@apache.org>
Subject Re: NiFi and MiNiFi Compatability?
Date Tue, 12 Mar 2019 01:42:42 GMT
Hi Jon,

The NiFi and MiNiFi releases are very loosely coupled — in general, any MiNiFi version will
work with any NiFi version (thus far). The only real concerns when aligning versions is the
availability of specific processors in NiFi being included in the JVM version of MiNiFi. Communication
between the two instances is usually via Site-to-Site protocol, which is robust and we take
pains not to introduce any compatibility-breaking changes in minor releases anyway. In addition,
you can use a variety of other communication mechanisms (FTP, file system, HTTP, MQTT, etc.)
from both endpoints if necessary. 

I have personally run MiNiFi 0.5.0 and 0.6.0-SNAPSHOT against NiFi 1.8.0, 1.9.0, and 1.10.0-SNAPSHOT
without encountering any problems. 


Andy LoPresto
alopresto@apache.org
alopresto.apache@gmail.com
PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69

> On Mar 11, 2019, at 5:38 PM, Jon Logan <jmlogan@buffalo.edu> wrote:
> 
> Hi All,
> 
> I was wondering if there are compatibility concerns between NiFi and
> MiNiFi? Specifically, it seems like the last release of MiNiFi is against
> 1.7 -- should we expect problems if we were to point this against the
> latest version of NiFi?
> 
> If so, are there any plans of trying to coordinate releases between the
> project and sub-project, even if its just to link against the same
> binaries? I was also curious if MiNiFi compatibility is considered during
> the NiFi release / testing process?
> 
> 
> Thanks!
> Jon


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message