nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John McGinn <>
Subject Compiling custom processor
Date Tue, 16 Oct 2018 13:36:50 GMT
Ok, I am far from a maven expert, and am struggling on this problem.

I created a new project using the maven generate process, and compiled that sample processor
and everything was fine, and I could see it in my local NiFi instance. I then copied over
the Wait processor on top of the class, changed the package name, and the
class name, and attempted to compile. Got errors due to dependency issues. This is where I
get confused.

In the processor directory, I modify the pom.xml with a dependency line for nifi-api, nifi-utils,
nifi-distribute-cache-client-service-api and nifi-standard-processors. This seemed to make
things work, and I get a 33 meg NAR file, which contains lots of JARs. I load that up, and
I get a problem with CalculateStats, or similar, because of RecordReaderFactory. I go back
in and include nifi-record-serialization-services, and it compiles, and the JAR is included
in the NAR file now, and I still get class not found.

I've also tried to change the dependencies to a status of provided, and therefore get a minimal
25k or so NAR file with no JARs included. I get the same issue with the class not found.

I had also attempted to copy to within the actually NiFi source
code, and it compiles, and shows up in the JARs and NARs as I'd expect, but I cannot get to
it within my NiFi instance.

Can someone let me know what I'm doing wrong.

John McGinn

View raw message