nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aldrin Piri <aldrinp...@gmail.com>
Subject Re: Setting NIFI_HTTP_WEB_HOST in Docker doesn't work
Date Tue, 27 Mar 2018 20:39:11 GMT
Hello,

Could you please try with NIFI_WEB_HTTP_HOST instead of NIFI_HTTP_WEB_HOST?
It seems we are lacking documentation around this, but stems from [1].

If that does not work, could you also verify you have the latest Docker
image and try again?  (docker pull apache/nifi:latest)

Using the latest image in conjunction with NIFI_WEB_HTTP_HOST, I am able to
verify successful hostname setting.  A couple quick commands to verify this
are:

docker run --name nifi \
  -p 9090:9090 \
  -d \
  -e NIFI_WEB_HTTP_PORT='9090' \
  -e NIFI_WEB_HTTP_HOST='puppytown' \
  apache/nifi:latest

I then verify the change occurred with the following:
docker exec nifi grep host /opt/nifi/nifi-1.5.0/conf/nifi.properties

[1]
https://github.com/apache/nifi/blob/master/nifi-docker/dockerhub/sh/start.sh#L24

On Tue, Mar 27, 2018 at 3:59 PM, Paulo & Claudio <claudioepaulo@gmail.com>
wrote:

> Hello. I have installed NiFi Docker on a Google Cloud Debian 9 server.
>
> The server has a public IP of PUBLIC_IP (placeholder for the real IP).
>
> I ran docker pull apache/nifi and it installed the image successfully.
>
> Then, I ran:
> sudo docker run --name nifi -p 8080:8080 -d -e NIFI_HTTP_WEB_HOST=PUBLIC_IP
> -e NIFI_HTTP_WEB_PORT=8080 apache/nifi:latest
>
> Since I set NIFI_HTTP_WEB_HOST to my PUBLIC_IP, and I have allowed the port
> 8080 in the Google Cloud console, I would assume that
> http://PUBLIC_IP:8080/nifi/ would work... instead, I get this:
>
> "System Error
> The request contained an invalid host header [PUBLIC_IP:8080] in the
> request [/nifi/]. Check for request manipulation or third-party intercept."
> When I run sudo docker logs nifi, I see the following warning:
>
> o.a.nifi.web.server.HostHeaderHandler Request host header [PUBLIC_IP:8080]
> different from web hostname [f3d104266d9a(:8080)]
>
> Any clue on why that might be happening?
>
> I found a few sites that suggested setting nifi.web.http.host in
> nifi.properties, but I don't know how to do that in Docker. Plus, I thought
> that the  NIFI_HTTP_WEB_HOST setting served exacly for that purpose. Am I
> missing something?
>
> Thank you in advance.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message