nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Koji Kawamura <ijokaruma...@gmail.com>
Subject Re: Help & advice needed on application.js in Processors
Date Wed, 31 Jan 2018 02:07:08 GMT
Hi Dave,

If you can confirm the updated application.js is included in the war
file, then it sounds like a matter of Web browser caching. The old
application.js cached at the client Web browser may be used. A hard
reload (Ctrl + Shift + R for Chrome) may help if that's the case.

Thanks,
Koji

On Wed, Jan 31, 2018 at 6:48 AM, DAVID SMITH <davidrsmith@btinternet.com> wrote:
> Hi
> I am trying to create a processor that is partially based on the UpdateAttribute processor
0.7.3.I have cloned the UpdateAttribute source, renamed the processor and I have started by
trying to amend the Advanced configuration UI. I have found that I can change labels for fields
in the Advanced configuration UI in WEB-INF/jsp/worksheet.jsp, and these are reflected in
the Advanced UI after a reload.
> However any changes that I make in webapp/js/application.js, such as changing the label
on the Rule FIlter button never gets picked up and displayed in the UI.I have unpacked the
war file and the application.js looks exactly as I have edited it.
> When I build the new processor  nar I am using mvn clean install, I am seeing no errors,
also when NiFi loads there are no errors or warnings.Is there a developers guide for creating
this type of UI in processors, or can someone help and tell me why my changes are not being
picked up?
> Many thanksDave

Mime
View raw message