nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Gilman <matt.c.gil...@gmail.com>
Subject Re: Chrome and 1.2.0 (SNAPSHOT)
Date Mon, 24 Apr 2017 17:21:42 GMT
No worries. Our cache-busting techniques append the current version to
resource paths. So when those resources change across versions, the browser
see's them as different and reloads them. When those resource change within
the same version (1.2.0-SNAPSHOT) you'll need to instruct your browser to
reload them either through clearing the cache or possibly performing a hard
reload.

Thanks

Matt

On Mon, Apr 24, 2017 at 1:18 PM, Mark Bean <mark.o.bean@gmail.com> wrote:

> Last week, the 'clear the cache' trick didn't help, so I forgot to try.
> This week (with the latest 1.2.0-SNAPSHOT changes), it helped. Good to go!
>
> Thanks for the reminder.
>
> -Mark
>
> On Mon, Apr 24, 2017 at 1:16 PM, Andy LoPresto <alopresto@apache.org>
> wrote:
>
> > Hi Mark,
> >
> > Could you please clear your cache and ensure the browser is not using
> > stored resources?
> >
> > Andy LoPresto
> > alopresto@apache.org
> > *alopresto.apache@gmail.com <alopresto.apache@gmail.com>*
> > PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69
> >
> > On Apr 24, 2017, at 10:13 AM, Mark Bean <mark.o.bean@gmail.com> wrote:
> >
> > Matt,
> >
> > The latest 1.2.0-SNAPSHOT (commit 57ccf97c) still exhibits the same
> > behavior. On Chrome (version 50.0.2661.94), NiFi will not get beyond the
> > spinning circle splash screen. On Firefox (version 31.5.0), it renders
> > correctly.
> >
> > Please re-open this ticket.
> >
> > Thanks,
> > Mark
> >
> >
> > On Fri, Apr 21, 2017 at 3:19 PM, Mark Bean <mark.o.bean@gmail.com>
> wrote:
> >
> > Thanks Matt.
> > We'll pull it down next week.
> >
> > On Fri, Apr 21, 2017 at 2:40 PM, Matt Gilman <matt.c.gilman@gmail.com>
> > wrote:
> >
> > Mark,
> >
> > A fix has been pushed to master. Let us know if you run into any other
> > issues.
> >
> > Thanks
> >
> > Matt
> >
> > On Fri, Apr 21, 2017 at 12:35 PM, Matt Gilman <matt.c.gilman@gmail.com>
> > wrote:
> >
> > Thanks. I think we figured out the issue. We've reopened the ticket [1]
> > where this was introduced. Sorry for the inconvenience.
> >
> > Matt
> >
> > [1] https://issues.apache.org/jira/browse/NIFI-3035
> >
> > On Fri, Apr 21, 2017 at 12:14 PM, Mark Bean <mark.o.bean@gmail.com>
> >
> > wrote:
> >
> >
> > For completeness, the error in the console prior to what I just posted
> > might also be relevant:
> >
> > POST https://<SERVER>:<PORT>/nifi-api/access/kerberos  409 (Conflict)
> > jquery.min.jsa:4
> >  send                 @ jquery.min.js:4
> >  r.extend.ajax        @ jquery.min.js:4
> >  (anonymous function) @ nf-canvas-all.js?1.2.0-SNAPSHOT:47
> >  r.extend.Deferred    @ jquery.min.js:2
> >  p.init               @ nf-canvas-all.js?1.2.0-SNAPSHOT:47
> >  (anonymous function) @ nf-canvas-all.js?1.2.0-SNAPSHOT:73
> >  j                    @ jquery.min.js:2
> >  k                    @ jquery.min.js:2
> >
> >
> > On Fri, Apr 21, 2017 at 11:49 AM, Mark Bean <mark.o.bean@gmail.com>
> > wrote:
> >
> > I cleared all browsing data (history, cookies, cached images and
> >
> > files,
> >
> > etc.), and refreshed. The Console shows:
> >
> > Uncaught TypeError: Cannot read property 'get' of undefined
> > nf-canvas-all.js?1.2.0-SNAPSHOT:15
> >  f.showDeepLink       @ nf-canvas-all.js?1.2.0-SNAPSHOT:15
> >  c.init               @ nf-canfas-all.js?1.2.0-SNAPSHOT:42
> >  (anonymous function) @ nf-canfas-all.js?1.2.0-SNAPSHOT:73
> >  i                    @ jquery.min.js:2
> >  j.fireWith           @ jquery.min.js:2
> >  (anonymous function) @ jquery.min.js:2
> >  i                    @ jquery.min.js:2
> >  j.fireWith           @ jquery.min.js:2
> >  A                    @ jquery.min.js:4
> >  (anonymous function) @ jquery.min.js:4
> >
> >
> > On Fri, Apr 21, 2017 at 11:31 AM, Matt Gilman <
> >
> > matt.c.gilman@gmail.com>
> >
> > wrote:
> >
> > The official browser support is documented in the User Guide [1].
> >
> > However,
> >
> > it sounds like you might be hitting a Javascript error. As Bryan
> > mentioned,
> > please verify there isn't anything cached. Once your good there,
> >
> > please
> >
> > check out the Console in the Chrome Dev Tools.
> >
> > Thanks
> >
> > Matt
> >
> > [1]
> > https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#
> > browser-support
> >
> > On Fri, Apr 21, 2017 at 11:28 AM, Bryan Rosander <
> >
> > brosander@apache.org
> >
> >
> > wrote:
> >
> > Hi Mark,
> >
> > To my knowledge there's no reason it shouldn't work in Chrome.
> >
> > Have
> >
> > you
> >
> > tried the "Empty Cache and Hard Reload" option to verify you don't
> >
> > have
> >
> > outdated javascript, etc files cached?
> >
> > Thanks,
> > Bryan
> >
> > On Fri, Apr 21, 2017 at 11:25 AM, Mark Bean <
> >
> > mark.o.bean@gmail.com>
> >
> > wrote:
> >
> >
> > I built 1.2.0-SNAPSHOT from master. It does not display on
> >
> > Chrome
> >
> > (version
> >
> > 50.0.2661.94). The splash page comes up, but it goes no
> >
> > further. It
> >
> > displays properly on Firefox (version 31.5.0). This was not a
> >
> > problem
> >
> > with
> >
> > NiFi 1.1.2.
> >
> > Is there a known minimum browser version for NiFi? Is there a
> >
> > particular
> >
> > feature that was added to 1.1.2 which would have caused this
> >
> > behavior?
> >
> > And
> >
> > can a fix be put in before a final 1.2.0 release?
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message