nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Zhurakousky <ozhurakou...@hortonworks.com>
Subject Re: Creating a custom DatabaseAdapter
Date Fri, 17 Feb 2017 13:17:37 GMT
Stanislav

Sorry to hear you’re having problems. 
Is ether any way we can look at the code (i.e., via GitHub)? Also, when you say you don’t
see your DatabaseAdapter is not picked up, do you see any messages in the logs?

It is hard to determine the issue without more info, but usually symptoms like this point
to miss-configuration of some type and are usually very easy to fix, once diagnosed. 
Let us know what you can do.

Also, a lot of times i helps to just copy another working bundle, then rename the artifact(s),
build and make sure you can see it being deployed. Now you can modify the code any way you
like knowing that at the very least you don’t have any configuration issues.

Let us know
Cheers
Oleg
> On Feb 17, 2017, at 5:05 AM, Stanislav <egl2000@yandex.com> wrote:
> 
> Hi,
> 
> I would like to create a custom org.apache.nifi.processors.standard.db.DatabaseAdapter,
is this possible?
> I have tried creating new class that implements the interface and specified the full
class name in META-INF\services\org.apache.nifi.processors.standard.db.DatabaseAdapter file,
and created a nar.
> But this does not appear to be working, the custom processor i have in that nar are picked-up
but the DatabaseAdapter isn`t.
> Any tips on how to make it work?
> 
> Best regards,
> Stanislav.
> 

Mime
View raw message