nifi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessio Palma <alessio.pa...@docomodigital.com>
Subject Re: NIFI 1.1.0 build error
Date Thu, 15 Dec 2016 13:10:37 GMT
Can I have your settings.xml which is located in ~/.m2 ?

________________________________
From: Oleg Zhurakousky <ozhurakousky@hortonworks.com>
Sent: Thursday, December 15, 2016 1:14:42 PM
To: dev@nifi.apache.org
Subject: Re: NIFI 1.1.0 build error

Alessio

Any chance you have some network connectivity issues when you attempt too build or may be
a proxy that restricts certain sites?
This error is indeed strange and I can’t recall having it and I’ve tried to do the same
(as you describe) on my mac and all builds fine.

Also, just to compare the environments:
olegs-mac:~ foo$ mvn --version
Apache Maven 3.3.3 (7994120775791599e205a5524ec3e0dfe41d4a06; 2015-04-22T07:57:37-04:00)
Maven home: /usr/local/Cellar/maven/3.3.3/libexec
Java version: 1.8.0_112, vendor: Oracle Corporation
Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/Home/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "mac os x", version: "10.11.2", arch: "x86_64", family: "mac"

Cheers
Oleg

> On Dec 15, 2016, at 6:49 AM, Alessio Palma <alessio.palma@docomodigital.com> wrote:
>
> Hello all,
>
> I downloaded the source code from
>
>
> http://apache.panu.it/nifi/1.1.0/nifi-1.1.0-source-release.zip
>
>
> then unpacked the archivie and executed:
>
>
> mvn dependency:purge-local-repository
>
> mvn clean install
>
>
> and I got this:
>
>
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-remote-resources-plugin:1.5:process
(default) on project nifi-standard-processors: Error resolving project artifact: Could not
transfer artifact com.martiansoftware:macnificent:pom:0.2.0 from/to org.apche.nifi (http://https://mvnrepository.com/artifact/org.apache.nifi):
https: unknown error for project com.martiansoftware:macnificent:jar:0.2.0: Unknown host https:
unknown error ->
>
>
>
> any pointers how to fix this ?


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message