nifi-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aldrin Piri (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MINIFI-151) CRC not matching for Site to Site on RPi
Date Sat, 03 Dec 2016 03:45:58 GMT
Aldrin Piri created MINIFI-151:
----------------------------------

             Summary: CRC not matching for Site to Site on RPi
                 Key: MINIFI-151
                 URL: https://issues.apache.org/jira/browse/MINIFI-151
             Project: Apache NiFi MiNiFi
          Issue Type: Bug
          Components: Data Transmission
    Affects Versions: cpp-0.1.0
         Environment: Raspberry Pi 2, Model B
Raspbian Jessie
            Reporter: Aldrin Piri


>From the 0.1.0 release, a community member reported some issues on a Raspberry Pi.  That
thread follows:

{quote}

- In addition to my laptop, I compiled and ran on a Raspberry Pi 2 Model B
running Raspbian Jesse, and I had the Pi connected to my laptop over
ethernet... It would connect to NiFi on my laptop and send some data
successfully, but then sometimes I would see this:

[2016-11-30 22:32:38.635] [minifi log] [info] Site2Site Send FINISH
TRANSACTION for transaction 71e57d6e-c251-4f35-ad99-3023ddf9771a
[2016-11-30 22:32:38.639] [minifi log] [info] Site2Site transaction
71e57d6e-c251-4f35-ad99-3023ddf9771a peer confirm transaction with CRC
3404584822
[2016-11-30 22:32:38.639] [minifi log] [info] Site2Site transaction
71e57d6e-c251-4f35-ad99-3023ddf9771a CRC not matched -890382474
[2016-11-30 22:32:38.639] [minifi log] [info] Site2Site delete transaction
71e57d6e-c251-4f35-ad99-3023ddf9771a

Then at the same time in the NiFi logs I would see this:

2016-11-30 17:38:50,162 INFO [Site-to-Site Worker Thread-67]
o.a.nifi.remote.SocketRemoteSiteListener Successfully negotiated
ServerProtocol SocketFlowFileProtocol Version 5 with
Peer[url=nifi://raspberrypi.local:35510]2016-11-30 17:38:50,289 ERROR
[Site-to-Site Worker Thread-67] o.a.nifi.remote.SocketRemoteSiteListener
Unable to communicate with remote instance
Peer[url=nifi://raspberrypi.local:35510]
(SocketFlowFileServerProtocol[CommsID=77842d17-b31d-4601-9f0d-38fd0b2fc7cc])
due to org.apache.nifi.processor.exception.ProcessException:
java.io.IOException:
SocketFlowFileServerProtocol[CommsID=77842d17-b31d-4601-9f0d-38fd0b2fc7cc]
Received a BadChecksum response from peer
Peer[url=nifi://raspberrypi.local:35510]; closing connection

Once it got into this state I would have to restart the process, and
sometimes this would even happen on the first file I tried to send through.

It is most likely something in my environment since everything worked fine
when it was local on my laptop, and I believe Koji and maybe a few others
ran on a Raspberry Pi as well, but I thought I would mention it in case it
turns out to be an actual issue.
{quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message