nifi-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MINIFI-115) Upgrade NiFi dependencies to 1.0
Date Mon, 14 Nov 2016 21:52:58 GMT

    [ https://issues.apache.org/jira/browse/MINIFI-115?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15665153#comment-15665153
] 

ASF GitHub Bot commented on MINIFI-115:
---------------------------------------

Github user apiri commented on a diff in the pull request:

    https://github.com/apache/nifi-minifi/pull/43#discussion_r87866531
  
    --- Diff: minifi-assembly/src/main/assembly/dependencies.xml ---
    @@ -36,23 +36,38 @@
                 	<exclude>minifi-bootstrap</exclude>
                     <exclude>minifi-resources</exclude>
                     <!-- Filter items introduced via transitive dependencies that are
provided in associated NARs -->
    +                <exclude>org.apache.nifi:nifi-framework-core:1.0.0</exclude>
    +                <exclude>zookeeper</exclude>
                     <exclude>spring-aop</exclude>
                     <exclude>spring-context</exclude>
    -                <exclude>spring-security-core</exclude>
                     <exclude>spring-beans</exclude>
    +                <exclude>spring-expression</exclude>
                     <exclude>swagger-annotations</exclude>
                     <exclude>slf4j-log4j12</exclude>
                     <exclude>aspectjweaver</exclude>
                     <exclude>h2</exclude>
                     <exclude>netty</exclude>
                     <exclude>jaxb-impl</exclude>
    -                <exclude>httpclient</exclude>
                     <exclude>mail</exclude>
                     <exclude>log4j</exclude>
    +                <exclude>lucene-analyzers-common</exclude>
                     <exclude>lucene-queryparser</exclude>
                     <exclude>commons-net</exclude>
    +                <exclude>spring-context</exclude>
    +                <exclude>spring-security-core</exclude>
                 </excludes>
             </dependencySet>
    +        <dependencySet>
    +            <scope>runtime</scope>
    +            <useProjectArtifact>false</useProjectArtifact>
    +            <outputDirectory>lib</outputDirectory>
    --- End diff --
    
    This is to provide explicit inclusion of the following artifacts.  I found out the tough
way that the include/exclude directives will do a simple pattern matching.  So nifi-framework-core
also excludes minifi-framework-core given the match.  Will put a comment on this to clarify.
 Had one at some point, but got lost to the sands of time and many iterations.


> Upgrade NiFi dependencies to 1.0
> --------------------------------
>
>                 Key: MINIFI-115
>                 URL: https://issues.apache.org/jira/browse/MINIFI-115
>             Project: Apache NiFi MiNiFi
>          Issue Type: Task
>          Components: Core Framework
>    Affects Versions: 0.0.1
>            Reporter: Aldrin Piri
>            Assignee: Aldrin Piri
>             Fix For: 0.1.0
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message