nifi-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Witt (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (NIFI-1198) Processor InputRequirement indicating invalid when it should be valid
Date Wed, 25 Nov 2015 20:29:11 GMT

    [ https://issues.apache.org/jira/browse/NIFI-1198?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15027543#comment-15027543
] 

Joseph Witt commented on NIFI-1198:
-----------------------------------

full clean build with contrib check legit.  tested flow to reproduce and appears resolved

+1 

will merge

> Processor InputRequirement indicating invalid when it should be valid
> ---------------------------------------------------------------------
>
>                 Key: NIFI-1198
>                 URL: https://issues.apache.org/jira/browse/NIFI-1198
>             Project: Apache NiFi
>          Issue Type: Bug
>    Affects Versions: 0.4.0
>            Reporter: Bryan Bende
>            Assignee: Matt Gilman
>            Priority: Minor
>             Fix For: 0.4.0
>
>         Attachments: 0001-NIFI-1198.patch
>
>
> I had connected several processors in a line and had them all valid and ready to be started.
I then decide to remove one processor from the path, so lets say I had Proc1 connected to
Proc2 connected to Proc3. I deleted the connection between Proc2 and Proc3, then dragged the
existing connection between Proc1 and Proc2 to make it go from Proc1 to Proc3. At this point
everything should have been valid, but Proc3 said it was invalid because it required input.
If I deleted this connection and created a new one between Proc1 and Proc3 then all was good.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message