netbeans-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aurélien Adamezyk <aurelien.adame...@gaboweb.net>
Subject [PHP] Make XDebug working with Netbeans 12.0 and WSL on Windows 10
Date Tue, 23 Jun 2020 15:37:25 GMT
Hello,

I'm struggling to make XDebug work with Apache2 on a WSL (Ubuntu 18.04)
instance.
Apache and the website are correctly configured on WSL and working.
Website files are in the directory /var/www/myproject which is a
symbolic link to /mnt/d/myproject
Netbeans uses D:\myproject directory and it seems to be ok too.

I've installed php-xdebug on Ubuntu and here is config file :

zend_extension=xdebug.so
xdebug.remote_enable=on
xdebug.remote_handler=dbgp
xdebug.remote_host=localhost
xdebug.remote_autostart=1
xdebug.remote_port=9000
xdebug.remote_mode="req"
xdebug.idekey="netbeans-xdebug"
xdebug.extended_info=On
xdebug.remote_log="/var/log/xdebug.log"
xdebug.remote_connect_back = 1
xdebug.show_local_vars=on
xdebug.var_display_max_children = 16
xdebug.var_display_max_data = 4096
xdebug.var_display_max_depth = 16

I did not change Netbeans Debugging general parameters, and when
launching debug session Netbeans succeeded in connecting to XDebug, but
breakpoints did not work.
After reading over the net, I tried to add Path Mapping like that :
\var\www\myproject => D:\myproject
Now when debug is launched Netbeans stops on my breakpoint but I have no
green pointer (I have to go to Call Stack to know that it is ok). I
tried somes changes on Ubuntu and Netbeans but with no result. I hope
someone can help me because I think it is just a little step missing to
make it working.

Thanks !


Mime
View raw message