netbeans-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paolo Scarabelli <pa...@msw.it>
Subject Re: Netbeans 11.1 and Xdebug
Date Thu, 22 Aug 2019 08:26:23 GMT
Hi, xdebug works for me with Netbeans 11.1.

My configuration is:

Netbeans (Tools->Options->PHP->Debugging):
Debugger port: 9000
Session ID: netbeans-xdebug
Maximum data length: 2048
All remaining checkboxes are unchecked.

xdebug.ini (/etc/php/7.3/apache2/conf.d/20-xdebug.ini):
zend_extension=xdebug.so
xdebug.remote_enable=on
xdebug.remote_handler=dbgp
xdebug.remote_host=localhost
xdebug.remote_mode=req
xdebug.remote_port=9000
xdebug.show_local_vars=on
;xdebug.force_display_errors=1
;xdebug.force_error_reporting = E_ALL
;xdebug.show_exception_trace=1
xdebug.var_display_max_children = 16
xdebug.var_display_max_data = 4096
xdebug.var_display_max_depth = 16

A few notes:
1. You may have multiple xdebug.ini in your system, make sure you edit the
right one (normally there is at least one for CLI and another for Apache2).
2. in remote_host you can try to replace localhost with 127.0.0.1
3. Don't forget to restart the relevant server (i.e. apache) after editing.

Regards,

Paolo


On Thu, Aug 22, 2019 at 2:59 AM Haunted2 <haunted2@gmx.com> wrote:

> Does anybody managed to have Xdebug working in Netbeans 11.1? I tried in
> many ways following the official documentation (
> http://wiki.netbeans.org/HowToConfigureXDebug) and non official tutorials
> but Netbeans is always stuck on "waiting for connection."
>
> [image: waiting for connection]
>
> The xdebug extension itself is loaded (as shown from phpinfo()) and it is
> working in a different ide (vs code).
>
> Any help is appreciated.
>
> Thanks.
>
>

Mime
View raw message