Hi Geertjan

It was a network related issue. I'd assigned the laptop a meaningless hostname. 

I've associated it to the loopback address and it works fine now. 



On Mon, 25 Mar 2019, 17:50 Geertjan Wielenga, <geertjan.wielenga@googlemail.com> wrote:
Seems like you’re not online or have a network problem. Maybe something with proxies.


On Mon, 25 Mar 2019 at 18:33, James W <jaylascousa@gmail.com> wrote:
Hi folks,

I've installed Netbeans from source on OpenSUSE. I'm using Oracle JDK8 and Ant 10.

I've installed the application to /usr/local/bin/netbeans and made that directory owned by my user account.

I can launch the IDE OK but when I open a PHP project it shows an exclamation mark and when I click on Resolve Problems I get the following error:

        Feature FeatureInfo[webcommon] is incomplete: some module(s) are missing: org.netbeans.libs.oracle.jsparser     

I thought it might be a plugin not working but when I check out the plugins I can't retrieve the available list from online and the installed plugins shows 9 installed but only the IDE is enabled. The other web related ones (HTML5 / PHP) when I attempt to enable them show the following message:

Some plugins require plugin org.netbeans.libs.oracle.jsparser to be installed.

The plugin named org.netbeans.libs.oracle.jsparser is needed and not found.     

The others (Ruby / Java SE + FX / Netbeans Development) present this message:

Some plugins require plugin org.netbeans.modules.nbjavac to be installed.

The plugin named org.netbeans.modules.nbjavac is needed and not found.

I did manage to enable Tools and Service Registry thinking it might be a dependency problem but still the same issue.

I'm guessing it's a path issue perhaps because of the way I've installed it and run it.

I thought it might have been because I'd not launched as described, I'd added the bin directory to path and was launching just typing netbeans.

I've removed the .netbeans and .cache/netbeans directories from the my home folder and launched using the command ./nbbuild/netbeans/bin/netbeans but I still get the same issue.

It does show me an error on startup which refers to the hostname of the laptop. I didn't think this was the problem, but perhaps it is?

java.net.UnknownHostException: biglap: biglap: Name or service not known
at java.net.InetAddress.getLocalHost(InetAddress.java:1506)
at org.netbeans.CLIHandler$2.run(CLIHandler.java:642)
at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:45)
at org.openide.util.lookup.Lookups.executeWith(Lookups.java:278)
at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2033)

If you have anything to try please let me know.

Thank you,