netbeans-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geertjan Wielenga <geertjan.wiele...@googlemail.com.INVALID>
Subject Re: Chrome with NetBeans Connector Error
Date Fri, 26 Oct 2018 14:41:24 GMT
Here are the source of the plugin, donated to Apache, so it's all good,
pull requests welcome:

https://github.com/apache/incubator-netbeans/tree/master/webcommon/extbrowser.chrome/plugins/chrome

Gj

On Fri, Oct 26, 2018 at 7:23 AM Bayless <bkirt@cox.net> wrote:

> That seems to be right. I recently got an update to Chrome on Linux Mint
> and started getting the same error. It didn't bother me though so I just
> ignored it. I'm sure the same will happen on Ubuntu.
>
>
> On 10/26/18 9:16 AM, John Lavelle wrote:
>
> Yes, I'm using the latest version of Chrome and Chromium on all platforms.
>
> If you find the code for the Connector and want someone to look at it,
> I'll certainly give it a go.
>
> Best regards,
> John
> john@jql.co.uk
>
>
> On Fri, 26 Oct 2018 at 16:07, Geertjan Wielenga
> <geertjan.wielenga@googlemail.com.invalid>
> <geertjan.wielenga@googlemail.com.invalid> wrote:
>
>> Basically the problem is that you've upgraded Chrome to some version that
>> the Connector does not support. Either you need to downgrade to a level
>> where the Connector supports it or we need to update or tweak the Connector
>> somehow. Not sure where that source code is nor whether it has been donated
>> or is scheduled yet, will take a look.
>>
>> Gj
>>
>> On Fri, Oct 26, 2018 at 7:00 AM John Lavelle <john@jql.co.uk> wrote:
>>
>>> Hi,
>>>
>>> I've started to get an error when using Chrome with the NetBeans
>>> Connector. The error is:
>>>
>>> *Browser refused to debug this tab.*
>>> *Close Chrome Developer Tools (or any other browser debugger) and try
>>> again.*
>>>
>>> To replicate:
>>>
>>> Create an HTML page and use Chrome with NetBeans Connector in the
>>> project properties. Press F6 (or run the page) and the error occurs.
>>>
>>> I've tried this on the following NetBeans and get the same error:
>>>
>>>    - 8.2 for Windows
>>>    - 9.0 for Windows
>>>    - 8.2 for Linux (Mint)
>>>    - 9.0 for Linux (Mint)
>>>    - 9.0 for Linux (Mint) with Chromium (clean install with default
>>>    install settings)
>>>
>>> I'm about to try it on Ubuntu 18.04 but I suspect the same error will be
>>> thrown.
>>>
>>> I have CDT (Chrome Developer Tools) switched off as suggested and, just
>>> in case, switched on as well. There is no difference.
>>>
>>> I'm of the opinion, though have no proof, that this could be a Chrome
>>> issue.
>>>
>>> Can anyone else replicate it?
>>> Does anyone know of a work-round or fix (other than not using NetBeans
>>> Connector)?
>>>
>>> Many thanks in advance.
>>>
>>> Best regards,
>>> John
>>>
>>>

Mime
View raw message