netbeans-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Mills <David.Mi...@medibank.com.au>
Subject RE: Netbeans CPU use
Date Mon, 14 May 2018 07:13:26 GMT
The full profile attached.

Regards,

David Mills | Senior Technical Analyst | Medibank Private
Level 1, 720 Bourke Street, Docklands, VIC, 3008 | Tel: 03 8622 5346 | Mob: 0411 513 404

From: David Mills
Sent: Monday, 14 May 2018 17:12
To: 'Bruno Flávio' <email@brunoflavio.com>; users@netbeans.apache.org
Subject: RE: Netbeans CPU use

Hi Bruno,

Yes - it seems to happen exclusively in Groovy projects.  I've never noticed in other.  None
of our other developers use Groovy and they never experience the same.  I rarely use Java
or other projects.  So I can't say for certain that its Groovy and not something about my
environment.

The profile shows the following as the mamximum CPU usage line:
com.sun.jna.Native.invokeInt[native] ()               352,452 ms (99.7%)         352,452 ms
(99.7%)

under W32 File Monitor.  Does that provide enough information?

Regards,

David Mills | Senior Technical Analyst | Medibank Private
Level 1, 720 Bourke Street, Docklands, VIC, 3008 | Tel: 03 8622 5346 | Mob: 0411 513 404

From: Bruno Flávio [mailto:email@brunoflavio.com]
Sent: Monday, 14 May 2018 16:57
To: users@netbeans.apache.org<mailto:users@netbeans.apache.org>
Subject: Re: Netbeans CPU use

Hi,

You could take a snapshot with NetBeans profiler or the Java mission control application to
see what's going on.

Is this happening exclusively with the groovy project? In 9.0 you installed the groovy support
modules manually?

Best regards,
-Bruno Flavio
On 14 May 2018 06:28:43 WEST, David Mills <David.Mills@medibank.com.au<mailto:David.Mills@medibank.com.au>>
wrote:
Hi all,

I use Netbeans with a few projects - one of which is Groovy based.  When I run with that project
Netbeans starts using excessive CPU.  Restarting Netbeans resolves the issue for about 30
mins to 2 hours.  How can I diagnose what is using the CPU and how can I stop it.  The UI
seems completely idle - there's no evidence of anything in progress.

This has been the case for releases 8.2, latest development and the release candidate for
9.0.

I'm running on Windows Server 2012 on an AWS hosted VM.

Regards,

David Mills | Senior Technical Analyst | Medibank Private
Level 1, 720 Bourke Street, Docklands, VIC, 3008 | Tel: 03 8622 5346 | Mob: 0411 513 404


The information contained in or attached to this message is intended only for the people it
is addressed to. If you are not the intended recipient, please notify the sender and delete
the email. Any use, disclosure or copying of this information is unauthorised and prohibited.
This information may be confidential or subject to legal privilege. It is not the expressed
view of Medibank Private Limited (ABN 47 080 890 259) or any of its subsidiaries (together
'Medibank') unless it is authorised by a person with actual authority. To the fullest extent
allowed by law, Medibank does not accept liability for any damage caused by this message,
including any virus damage.

The information contained in or attached to this message is intended only for the people it
is addressed to. If you are not the intended recipient, please notify the sender and delete
the email. Any use, disclosure or copying of this information is unauthorised and prohibited.
This information may be confidential or subject to legal privilege. It is not the expressed
view of Medibank Private Limited (ABN 47 080 890 259) or any of its subsidiaries (together
'Medibank') unless it is authorised by a person with actual authority. To the fullest extent
allowed by law, Medibank does not accept liability for any damage caused by this message,
including any virus damage.

Mime
View raw message