netbeans-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geertjan Wielenga <geertjan.wiele...@googlemail.com>
Subject Re: netbeans 9.0 rc1 : cannot update plugins : java source base version 2 required
Date Tue, 29 May 2018 15:24:18 GMT
Great.

If you encounter this or any other problems while you're sticking to the
basics, i.e., not installing anything, let us know.

The best way Apache NetBeans can be supported right now is to take the rc1
for a spin without doing anything special, i.e., don't install plugins,
don't do weird things, just be a plain old Java SE programmer for a while...

Thanks,

Gj



On Tue, May 29, 2018 at 5:19 PM, hanasaki@gmail.com <hanasaki@gmail.com>
wrote:

> Thank you!  Great responses and quick!
>
> working on jdk10 with default plugins out of the box.
>
> Installed some plugins from the built-in updater and it fails to start
> after plugin install.  Maybe I will stick to the basics until another RC or
> full release however would like to stick to NB using it for java 9 and/or
> 10.
>
> java.lang.UnsatisfiedLinkError: no splashscreen in java.library.path:
> [/usr/java/packages/lib, /usr/lib/x86_64-linux-gnu/jni,
> /lib/x86_64-linux-gnu, /usr/lib/x86_64-linux-gnu, /usr/lib/jni, /lib,
> /usr/lib]
>         at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.
> java:2654)
>         at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:876)
>         at java.base/java.lang.System.loadLibrary(System.java:1875)
>         at java.desktop/java.awt.SplashScreen$1.run(SplashScreen.java:134)
>         at java.desktop/java.awt.SplashScreen$1.run(SplashScreen.java:132)
>         at java.base/java.security.AccessController.doPrivileged(Native
> Method)
>         at java.desktop/java.awt.SplashScreen.getSplashScreen(SplashScr
> een.java:131)
>         at org.netbeans.core.startup.Splash.<init>(Splash.java:96)
>         at org.netbeans.core.startup.Splash.getInstance(Splash.java:59)
>         at org.netbeans.core.startup.Main.start(Main.java:271)
>         at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.
> java:98)
>         at java.base/java.lang.Thread.run(Thread.java:844)
>
>
> On 5/29/18 11:01 AM, Geertjan Wielenga wrote:
>
>> All of those are not and will not be supported by Apache NetBeans
>> (incubating) 9.0.
>>
>> They will be part of Apache NetBeans later, once their source code is in
>> the Apache NetBeans Git repo.
>>
>> If they work for you as plugins, great, but they're not supported, cannot
>> be blockers, are in no way at all part of the release -- and Darcula can be
>> installed by simply downloading the NBM and then manually installing it in
>> the Plugin Manager:
>>
>> http://plugins.netbeans.org/plugin/62424/darcula-laf-for-netbeans
>>
>> Gj
>>
>>
>>
>>
>> On Tue, May 29, 2018 at 4:58 PM, hanasaki@gmail.com <mailto:
>> hanasaki@gmail.com> <hanasaki@gmail.com <mailto:hanasaki@gmail.com>>
>> wrote:
>>
>>     need a couple plugs:  gradle, maven, slf4j, spring
>>     want: the dark theme
>>
>>     On 5/29/18 10:56 AM, Geertjan Wielenga wrote:
>>
>>         Maybe better to ignore NetBeans updates for the moment.
>>
>>         Gj
>>
>>         On Tue, May 29, 2018 at 4:32 PM, hanasaki@gmail.com
>>         <mailto:hanasaki@gmail.com> <mailto:hanasaki@gmail.com
>>         <mailto:hanasaki@gmail.com>> <hanasaki@gmail.com
>>         <mailto:hanasaki@gmail.com> <mailto:hanasaki@gmail.com
>>         <mailto:hanasaki@gmail.com>>> wrote:
>>
>>              installed rc1 (linux openjdk9 with the source package too -
>>         on debian 9)
>>              java -version
>>              openjdk version "9-Debian"
>>              OpenJDK Runtime Environment (build 9-Debian+0-9b181-4bpo91)
>>              OpenJDK 64-Bit Server VM (build 9-Debian+0-9b181-4bpo91,
>>         mixed mode)
>>
>>              netbeans updates are available however the following error is
>>              reported.  This happened with the beta's and with jdk10 too.
>>
>>              Some plugins require plugin Java Source Base to be installed.
>>              The plugin Java Source Base is requested in implementation
>>         version 2.
>>                       The following plugin is affected: Java Shell Support
>>
>>                     ------------------------------
>> ---------------------------------------
>>              To unsubscribe, e-mail:
>>         users-unsubscribe@netbeans.apache.org
>>         <mailto:users-unsubscribe@netbeans.apache.org>
>>              <mailto:users-unsubscribe@netbeans.apache.org
>>         <mailto:users-unsubscribe@netbeans.apache.org>>
>>              For additional commands, e-mail:
>>         users-help@netbeans.apache.org
>>         <mailto:users-help@netbeans.apache.org>
>>              <mailto:users-help@netbeans.apache.org
>>         <mailto:users-help@netbeans.apache.org>>
>>
>>              For further information about the NetBeans mailing lists,
>>         visit:
>>         https://cwiki.apache.org/confluence/display/NETBEANS/Mailing
>> +lists
>>         <https://cwiki.apache.org/confluence/display/NETBEANS/Mailin
>> g+lists>
>>                     <https://cwiki.apache.org/conf
>> luence/display/NETBEANS/Mailing+lists
>>         <https://cwiki.apache.org/confluence/display/NETBEANS/Mailin
>> g+lists>>
>>
>>
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@netbeans.apache.org
> For additional commands, e-mail: users-help@netbeans.apache.org
>
> For further information about the NetBeans mailing lists, visit:
> https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists
>
>

Mime
View raw message