netbeans-netcat mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Wolf <tjw...@gmail.com>
Subject Mac - can’t run project
Date Wed, 21 Mar 2018 23:16:18 GMT
Hi everyone,
 I just now finally had some time to install NB 9, I hope someone can answer it:

I just downloaded the NB master branch from GitHub and everything built fine on my Mac.  NB
9 itself seems to run fine as well (using JDK 1.8_172).  But whenever I try to run my simply
test project, I get a runtime error:
run:

Exception in thread "main" java.lang.RuntimeException: 
at sasdatasetreader.SASDatasetReader.main(SASDatasetReader.java:1)
/Users/thwolf/Library/Caches/NetBeans/dev/executor-snippets/run.xml:111: The following error
occurred while executing this line:
/Users/thwolf/Library/Caches/NetBeans/dev/executor-snippets/run.xml:94: Java returned: 1
BUILD FAILED (total time: 3 seconds)

I tried running it with JDK 9 as the runtime platform, but same thing - runtime error (just
slightly different wording).  I don't see anything in the IDE log that points to any problem
and when I run the command the output window tells me to run the application with, it works
fine:
/Library/Java/JavaVirtualMachines/jdk1.8.0_172.jdk/Contents/Home/bin/java -jar "/Users/thwolf/NetBeansProjects/SASDatasetReader/dist/SASDatasetReader.jar"

I'm running on macOS (10.13.3).  The same project runs fine in NB 8.2.

Does anyone know what’s going on?  I will try running an even simpler project next, I guess.

Thanks a bunch,
Tom

---------------------------------------------------------------------
To unsubscribe, e-mail: netcat-unsubscribe@netbeans.apache.org
For additional commands, e-mail: netcat-help@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists


Mime
View raw message