netbeans-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Lenz (Jira)" <j...@apache.org>
Subject [jira] [Created] (NETBEANS-3185) Java frontend application doesn't work
Date Mon, 30 Sep 2019 14:45:00 GMT
Christian Lenz created NETBEANS-3185:
----------------------------------------

             Summary: Java frontend application doesn't work
                 Key: NETBEANS-3185
                 URL: https://issues.apache.org/jira/browse/NETBEANS-3185
             Project: NetBeans
          Issue Type: Bug
          Components: javafx - Project, platform - HTML4J
    Affects Versions: 11.2
         Environment: Product Version: Apache NetBeans IDE 11.2-beta1
Java: 11.0.2; Java HotSpot(TM) 64-Bit Server VM 11.0.2+9-LTS
Runtime: Java(TM) SE Runtime Environment 11.0.2+9-LTS
System: Windows 10 version 10.0 running on amd64; Cp1252; de_DE (nb)
User directory: C:\Users\Chrl\AppData\Roaming\NetBeans\11.2-beta1
Cache directory: C:\Users\Chrl\AppData\Local\NetBeans\Cache\11.2-beta1
            Reporter: Christian Lenz
         Attachments: netbeans-java-frontend.png

When I create a Java with Maven -> Java Frontend Application and try to run it as a NetBeans
plugin, it doesn't work. It shows me, that some modules can't be enabled. This happens for
a project type, that already exists in NetBeans w/o having a 3rd-party-plugin installed and
a clean install (no user dir, no cache, nothing). Just downloaded 11.2 beta 1 and started
it fresh.

As you can see, I'm running NetBeans 11.2 beta 1 on JDK 11.0.2 but I also have JDK 1.8 installed
and I build the project with JDK 1.8

Steps to reproduce:
* Create a new Project
* Choose "Java with Maven" -> "Java Frontend Application"
* Click on "Download & Activate" on the wizard for the project if needed.
* Wait for nbjavac and javafx downloaded and activate the missing features
* On wizard page "Name and Location" leave everything as it is and click next
* On next wizard page "Choose Platform" choose "Run as a NetBeans plugin" and click next
* On next wizard page "Select a template" leave everything as it is and click next
* On next wzard page "What will be created?" click finish
* Wait for everything is created and opened and you see the multi module project.
* Right click on your multi module project -> properties and go to sources
* Make sure that you have chosen 1.8 at "Source/Binary Format" (This is my environment, because
I have installed JDK 1.8 to build my plugins for the minimal version as possible)
* Build your project for your target platform. I tried for ANB 10.0 and 11.1
* Try to run your submodule "YourProjectName Client for NetBeans" in your target platform
* When NetBeans started the modules, you got the message that not all modules can be enabled.
See the screenshot for this.

Here is the output when I run the submodule
{code}
cd C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans; "JAVA_HOME=C:\\Program
Files\\Java\\jdk-11.0.2" cmd /c "\"\"C:\\Users\\Chrl\\Downloads\\netbeans 11.2 beta 1\\java\\maven\\bin\\mvn.cmd\"
-DskipTests=true -Dnetbeans.inspect.port=54481 -Dmaven.ext.class.path=\"C:\\Users\\Chrl\\Downloads\\netbeans
11.2 beta 1\\java\\maven-nblib\\netbeans-eventspy.jar\" -Dfile.encoding=UTF-8 -Pnetbeans-ide-10
package nbm:cluster nbm:run-platform\""
Scanning for projects...
                                                                        
------------------------------------------------------------------------
Building mavenproject4 Client for NetBeans 1.0-SNAPSHOT
------------------------------------------------------------------------

--- maven-enforcer-plugin:1.3.1:enforce (enforce-versions) @ mavenproject4-nb ---

--- maven-dependency-plugin:2.9:unpack-dependencies (unpack) @ mavenproject4-nb ---
Unpacking C:\Users\Chrl\.m2\repository\com\mycompany\mavenproject4\1.0-SNAPSHOT\mavenproject4-1.0-SNAPSHOT-webpages.zip
to C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\classes\com\mycompany\mavenproject4
with includes "*/**" and excludes ""

--- maven-compiler-plugin:3.3:compile (default-compile) @ mavenproject4-nb ---
Nothing to compile - all classes are up to date

--- image-maven-plugin:1.1:scale (default) @ mavenproject4-nb ---
Output file C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\classes\com\mycompany\mavenproject4\icon.png
skipped because it already exists
Output file C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\classes\com\mycompany\mavenproject4\icon24.png
skipped because it already exists

--- html4j-maven-plugin:1.6.1:process-js-annotations (js-classes) @ mavenproject4-nb ---

--- nbm-maven-plugin:3.14.1:manifest (default-manifest) @ mavenproject4-nb ---
NBM Plugin generates manifest
Adding OSGi bundle dependency - com.mycompany:mavenproject4
Adding OSGi bundle dependency - org.netbeans.html:net.java.html.boot
Adding OSGi bundle dependency - com.mycompany:mavenproject4-js

--- maven-resources-plugin:3.0.2:testResources (default-testResources) @ mavenproject4-nb
---
Using 'UTF-8' encoding to copy filtered resources.
skip non existing resourceDirectory C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\src\test\resources

--- maven-compiler-plugin:3.3:testCompile (default-testCompile) @ mavenproject4-nb ---
No sources to compile

--- maven-jar-plugin:2.4:jar (jar) @ mavenproject4-nb ---
Adding existing MANIFEST to archive. Found under: C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\classes\META-INF\MANIFEST.MF
Building jar: C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\mavenproject4-nb-1.0-SNAPSHOT.jar

--- nbm-maven-plugin:3.14.1:cluster-app (default-cluster-app) @ mavenproject4-nb ---
Could not resolve Class-Path item in org.netbeans.api:org-netbeans-libs-javafx:nbm-file:RELEASE110,
path is:${java.home}/lib/ext/jfxrt.jar, skipping
Could not resolve Class-Path item in org.netbeans.api:org-netbeans-libs-javafx:nbm-file:RELEASE110,
path is:${java.home}/lib/ext/jfxrt.jar, skipping
Integrity verification skipped.
Created NetBeans module cluster(s) at C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\netbeans

--- nbm-maven-plugin:3.14.1:standalone-zip (default-standalone-zip) @ mavenproject4-nb ---
Building zip: C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\mavenproject4-nb-1.0-SNAPSHOT.zip

--- nbm-maven-plugin:3.14.1:nbm (default-nbm) @ mavenproject4-nb ---
Copying module JAR to C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\netbeans\extra\modules
Generating Auto Update information for com.mycompany.mavenproject4.nb
No updater.jar specified, cannot validate Info.xml against DTD
Building jar: C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\mavenproject4-nb-1.0-SNAPSHOT.nbm
                                                                        
------------------------------------------------------------------------
Building mavenproject4 Client for NetBeans 1.0-SNAPSHOT
------------------------------------------------------------------------

--- nbm-maven-plugin:3.14.1:cluster (default-cli) @ mavenproject4-nb ---
Created NetBeans module cluster(s) at C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target
                                                                        
------------------------------------------------------------------------
Building mavenproject4 Client for NetBeans 1.0-SNAPSHOT
------------------------------------------------------------------------

--- nbm-maven-plugin:3.14.1:run-platform (default-cli) @ mavenproject4-nb ---
Executing: cmd.exe /X /C "C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\netbeans\bin\netbeans.exe
--console suppress --userdir C:\Users\Chrl\Documents\NetBeansProjects\mavenproject4\mavenproject4\client-netbeans\target\userdir
-J-Dnetbeans.logger.console=true -J-ea --branding netbeans --jdkhome "C:\Program Files\Java\jdk-11.0.2""
{code}

I didn't change any pom. I just created the project, built it and tried to run it.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@netbeans.apache.org
For additional commands, e-mail: commits-help@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists


Mime
View raw message