netbeans-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eduard Fekete (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (NETBEANS-2929) xdebug not working with NetBeans 11.1
Date Thu, 01 Aug 2019 07:44:00 GMT

    [ https://issues.apache.org/jira/browse/NETBEANS-2929?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16897842#comment-16897842
] 

Eduard Fekete commented on NETBEANS-2929:
-----------------------------------------

Update: This is definitely a Netbeans 11.1 bug. I just tried it from another webserver where
xdebug always works reliable since a year, but netbeans can't connect. I just get `Waiting
for Connection (netbeans-xdebug)` forever and the website loads forever. The log just says
`Log opened at 2019-08-01 07:40:51` and nothing happens. While it works perfectly fine in
8.2

> xdebug not working with NetBeans 11.1
> -------------------------------------
>
>                 Key: NETBEANS-2929
>                 URL: https://issues.apache.org/jira/browse/NETBEANS-2929
>             Project: NetBeans
>          Issue Type: Bug
>    Affects Versions: 11.1
>         Environment: Windows 10 64 bit
>            Reporter: Eduard Fekete
>            Priority: Major
>         Attachments: netbeans-2929-screenshot.png
>
>
> I tried xdebug 2.7.2 with PHP 7.2.5 running on a remote linux openSUSE server.
> It does not start the debugger and says "Waiting for debugger (netbeans-xdebug)" but
nothing happens.
> If I try it in NetBeans 8.2 then it works.
>  
> The configuration is the same in both NetBeans (Port, IDE key)
>  Java: jdk1.8.0_172, jre1.8.0_181
>  
> *Reproduction:*
>  # Install xdebug 2.7.2 from source by following instructions from here [https://github.com/xdebug/xdebug]
>  # Set the following in php.ini
> {code:java}
> [XDebug]
> zend_extension = /usr/lib64/php7/extensions/xdebug.so
> xdebug.remote_connect_back=0
> xdebug.force_display_errors=on
> xdebug.force_error_reporting=on
> xdebug.remote_enable=on
> xdebug.remote_handler=dbgp
> xdebug.remote_host=192.168.40.161   #replace with IP of your remote client where netbeans
runs
> xdebug.remote_port=51234
> xdebug.remote_timeout=3000
> xdebug.remote_mode=req
> xdebug.remote_log=/var/log/xdebug/xdebug.log
> xdebug.idekey = netbeans-xdebug
> xdebug.renite_enable = 1
> xdebug.max_nesting_level = 1000
> xdebug.profiler_enable_trigger = 1
> xdebug.profiler_output_dir = '/var/log/xdebug'{code}
> 3. Restart apache2 service
> 4. Check if xdebug is installed by checking phpinfo
> 5. open Netbeans 11.1
> 6. Go to Tools > Options -> PHP -> Debugging
> 7. set "Debugger Port" to 51234
> 8. set "Session ID" to netbeans-xdebug
> 9. open a test script
> 10. right click -> Debug File
> 11. Notice that "Wating for Connection (netbeans-xdebug)" shows forever and nothing happens.
> */var/log/xdebug/xdebug.log:*
> {code:java}
> [22426] Log opened at 2019-08-01 07:01:46
> [22426] I: Connecting to configured address/port: 192.168.40.161:51234.
> [22426] E: Time-out connecting to client (Waited: 3000 ms). :-(
> [22426] Log closed at 2019-08-01 07:01:49{code}
>  
> 12. Do the same on Netbeans 8.2 and notice that it works



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@netbeans.apache.org
For additional commands, e-mail: commits-help@netbeans.apache.org

For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists


Mime
View raw message