netbeans-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Flavius Stan (JIRA)" <>
Subject [jira] [Commented] (NETBEANS-1922) Netbeans not launching in the second execution
Date Tue, 12 Feb 2019 18:44:00 GMT


Flavius Stan commented on NETBEANS-1922:

I made more research work.


No, Netbeans not starts in any screen available, it launch the terminal, and immediately prompts
the message corresponding to a closing session. I still believe that is because netbeans can't
find an available display. I had a similar issue with Eclipse inside a docker.

More things that I noticed:

If in any moment logged in the macbook, I had the lid open, no matter if I start netbeans
with the lid closed, it will starts normally.

Example: I turn on the macbook in the library, and use it with the lid open, as a normal laptop,
never launch Netbeans. Then, I close the lid to get into sleep mode. Later, no matter how
much time passed, and if the pc neves shut down, in my desk, if I connect it to the dock,
with the displays connected and launch Netbeans, it will start as usual, everything okay.

Now imagine I shut down the macbook, and turn on again, but with the displays connected, and
the lid down, Netbeans never will start. Then I open the lid, to change the available displays
to 3, after that, I close the leap again, now only 2 displays, and launch Netbeans, It will
start as usual. 

I attached a video showing all the process:

[^VideoNetbeansEdited 2.7z.001][^VideoNetbeansEdited 2.7z.002]

I tried to build Netbeans but my self but I encounter some issues, I will try to resolve them,
and make a more deep research.




> Netbeans not launching in the second execution
> ----------------------------------------------
>                 Key: NETBEANS-1922
>                 URL:
>             Project: NetBeans
>          Issue Type: Bug
>          Components: ide - Welcome
>    Affects Versions: 10.0
>         Environment: MacOS Mojave 10.14.2; 
> openjdk version "11.0.1" 2018-10-16
> OpenJDK Runtime Environment 18.9 (build 11.0.1+13)
> OpenJDK 64-Bit Server VM 18.9 (build 11.0.1+13, mixed mode); 
> Netbeans 10.0
>            Reporter: Flavius Stan
>            Assignee: Laszlo Kishalmi
>            Priority: Major
>              Labels: Bug
>         Attachments: Captura de pantalla 2019-01-11 a las 21.54.12.png, VideoNetbeansEdited
2.7z.001, VideoNetbeansEdited 2.7z.002
> Netbeans 10 not launching after restart the computer. 
> I download the binaries for netbeans 10 at 2019-1-7 to use with MacOs Mojave 10.14.2,
openjdk 11.0.1. Executing the netbeans UNIX executable, it starts as usual, everything works
great till I shutdown the computer. When I power up the computer again and start netbeans,
it just not open, the icon appears in the dock and it automatically close, not loading screen.
I executed in the terminal, but it didn't prompt anything. I edit the netbeans.conf file and
set the path to jdk in the file, but it didn't work. I tried to set it in executing time with
the --jdkhome command but anything new. I set the working dir manually, I increase the memory
heap but any approach was unsuccessfully. Netbeans not starting.
> So I give up, and delete the folder with netbeans. Today, 2019/1/11, I download netbeans
again with more hope, and the first time I execute it, it prompts the image attached, I click
on disable modules and continue, and as the other day, It works great, everything was okay.
So I decided to restart the computer to see if the issue repeat. And after the restart, netbeans
not launching again. 

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

For further information about the NetBeans mailing lists, visit:

View raw message