mynewt-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ccoll...@apache.org
Subject [11/23] incubator-mynewt-newt git commit: newt; go version requirement is now 1.7.
Date Fri, 07 Apr 2017 19:36:12 GMT
newt; go version requirement is now 1.7.


Project: http://git-wip-us.apache.org/repos/asf/incubator-mynewt-newt/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-mynewt-newt/commit/23ce34bc
Tree: http://git-wip-us.apache.org/repos/asf/incubator-mynewt-newt/tree/23ce34bc
Diff: http://git-wip-us.apache.org/repos/asf/incubator-mynewt-newt/diff/23ce34bc

Branch: refs/heads/master
Commit: 23ce34bce0a18e50f07e795d5983978376548b77
Parents: 7a6d02d
Author: Marko Kiiskila <marko@runtime.io>
Authored: Wed Mar 8 14:45:39 2017 -0800
Committer: Marko Kiiskila <marko@runtime.io>
Committed: Thu Mar 9 14:00:33 2017 -0800

----------------------------------------------------------------------
 INSTALLING.md | 2 +-
 build.sh      | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-mynewt-newt/blob/23ce34bc/INSTALLING.md
----------------------------------------------------------------------
diff --git a/INSTALLING.md b/INSTALLING.md
index 885f6cf..0718925 100644
--- a/INSTALLING.md
+++ b/INSTALLING.md
@@ -11,7 +11,7 @@ when available.  To find these, please go to https://mynewt.apache.org/.
 # Installing From Source
 
 The newt tool is written in Go (https://golang.org/).  In order to build Apache
-Mynewt, you must have Go 1.5 or later installed on your system.  Please visit
+Mynewt, you must have Go 1.7 or later installed on your system.  Please visit
 the Golang website for more information on installing Go (https://golang.org/).
 
 Once you have Go installed, you can build newt by running the contained

http://git-wip-us.apache.org/repos/asf/incubator-mynewt-newt/blob/23ce34bc/build.sh
----------------------------------------------------------------------
diff --git a/build.sh b/build.sh
index d4f108f..9405e6b 100755
--- a/build.sh
+++ b/build.sh
@@ -26,7 +26,7 @@ expandpath() {
     )
 }
 
-### Ensure >= go1.5 is installed.
+### Ensure >= go1.7 is installed.
 go_ver_str="$(go version | cut -d ' ' -f 3)"
 go_ver="${go_ver_str#go}"
 
@@ -49,9 +49,9 @@ then
     go_min=0
 fi
 
-if [ ! "$go_maj" -gt 1 ] && [ ! "$go_min" -ge 5 ]
+if [ ! "$go_maj" -gt 1 ] && [ ! "$go_min" -ge 7 ]
 then
-    printf "* Error: go 1.5 or later is required (detected version: %s)\n" \
+    printf "* Error: go 1.7 or later is required (detected version: %s)\n" \
         "$go_maj"."$go_min".X
     exit 1
 fi


Mime
View raw message