myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Udo Schnurpfeil <udo.schnurpf...@irian.eu>
Subject Re: Fwd: Tobago 3.0.6 - Encoding problems with tc:textarea etc in tc:tabGroup
Date Wed, 23 May 2018 15:28:05 GMT
Hi Marko,

I can't reproduce the issue until now (no WAS 8.0 available).

I've a running example with WAS 8.5.5.13, this might help you to find
the error.

Here's what I've tested:

Starting WAS 8.5.5.13 via Docker (see
https://hub.docker.com/r/ibmcom/websphere-traditional/)

$ echo "test1234">PASSWORD
$ docker run --name test -h test -v $(pwd)/PASSWORD:/tmp/PASSWORD -p
9043:9043 -p 9443:9443 -d ibmcom/websphere-traditional:8.5.5.13-profile

Browse to https://localhost:9043/ibm/console/ and use wsadmin/test1234
to login.

Checkout my example (slightly modified Tobago 3.0.7-SNAPSHOT demo):

$ git clone https://github.com/lofwyr14/myfaces-tobago.git test
$ cd test
$ git checkout test-websphere-umlauts
$ mvn

Deploy tobago-example/tobago-example-demo/target/tobago-example-demo.war
into WAS e.g. on context path /demo

Check these URLs (different switchType):

https://localhost:9443/demo/faces/content/20-component/070-tab/00-client/tab-client.xhtml
https://localhost:9443/demo/faces/content/20-component/070-tab/01-ajax/tab-ajax.xhtml
https://localhost:9443/demo/faces/content/20-component/070-tab/02-server/tab-server.xhtml

If this is running for you, you may test to deploy the
tobago-example-demo.war in your 8.0 WAS.

Or you may test to deploy your application into the docker 8.5 WAS.

Hope that helps

Regards,

Udo

Am 23.05.18 um 15:35 schrieb Henning Nöth:
> FYI
> 
> 
> -------- Weitergeleitete Nachricht --------
> Betreff: Tobago 3.0.6 - Encoding problems with tc:textarea etc in
> tc:tabGroup
> Datum: Wed, 23 May 2018 12:54:18 +0000
> Von: Voß, Marko <marko.voss@cgi.com>
> Antwort an: MyFaces Discussion <users@myfaces.apache.org>
> An: users@myfaces.apache.org <users@myfaces.apache.org>
> 
> Hello,
> 
> we are using Tobago 3.0.6 as we have to support WebSphere 8.0.
> 
> We experience some issues. One of them is that we get encoding issues
> when sending german umlauts and other special characters as values of
> tc:textArea or tc:selectManyCheckbox as child components of tc:tabGroup.
> I validated this issue and figured out, that the encoding issues are
> already present in
> facesContext.getExternalContext().getRequestParameterMap().
> 
> For example: Having the text "Örtlichkeit" as a value of a tc:textArea
> component with id "test" results in a key-value-pair:
> 
> test=örtlichkeit
> 
> The encoding of the HTML document in the browser is displayed correctly
> as UTF-8.
> 
> Please help.
> 
> Kind regards,
> 
> Marko Voß
> 

-- 
Dipl.-Math. Udo Schnurpfeil - Managing Director
IRIAN Deutschland GmbH - Poststr. 1-3 - 26122 Oldenburg - Germany
mobile +49 174 9784746 - fax +49 441 99922161
mailto:udo.schnurpfeil@irian.eu - http://www.irian.eu/

Mime
View raw message