myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: MyFaces 2.2.0 ViewScoped AmbiguousResolutionException
Date Thu, 04 Sep 2014 20:25:16 GMT
the issue is wars of an ear inherit from "lib" beans so mf shouldn't
use it (can be done adding a bean with a generated name by webapp -
and get the name from the servlet context for instance)

on tomee side we can skip mf cdi beans in ear lib part if it can help


Romain Manni-Bucau
Twitter: @rmannibucau
Blog: http://rmannibucau.wordpress.com/
LinkedIn: http://fr.linkedin.com/in/rmannibucau
Github: https://github.com/rmannibucau


2014-09-04 22:23 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:
> @Leonardo: with ears?
>
>
> Romain Manni-Bucau
> Twitter: @rmannibucau
> Blog: http://rmannibucau.wordpress.com/
> LinkedIn: http://fr.linkedin.com/in/rmannibucau
> Github: https://github.com/rmannibucau
>
>
> 2014-09-04 22:12 GMT+02:00 Leonardo Uribe <lu4242@gmail.com>:
>> Hi
>>
>> I have tested the latest snapshot from trunk and it is working with tomee
>> 1.7.0. I don't see any exception from this side.
>>
>> regards,
>>
>> Leonardo Uribe
>>
>>
>> 2014-09-03 17:23 GMT-05:00 José Luis Cetina <maxtorzito@gmail.com>:
>>
>>> Hi, i was trying to use MyFaces 2.2.4 with TomEE 1.7.0 JAX-RS, i want to
>>> use myfaces 2.2.4 because i want to use the @javax.faces.view.ViewScoped (i
>>> use the omnifaces viewscoped) and the f:viewAction.
>>>
>>> But again im getting javax.enterprise.inject.AmbiguousResolutionException:
>>> Ambiguous resolution exception that i reported a few months ago, apparently
>>> myfaces 2.2.4 is not working with ears in tomee 1.7.0.
>>>
>>> I already reported to tomee mailing list but @Romain sayed
>>>
>>> "think so but more a MF issue this time I think"
>>>
>>> @Leonardo
>>>
>>>
>>>
>>>
>>> 2014-01-15 17:14 GMT-06:00 Howard W. Smith, Jr. <smithh032772@gmail.com>:
>>>
>>> > if you are not able to use MyFaces 2.2 @ViewScoped, you may need to keep
>>> > OmniFaces CDI @ViewScoped until someone helps you with your issue.
>>> >
>>> > Some months ago, I tested MyFaces 2.2 with OmniFaces CDI @ViewScoped; all
>>> > of my @ViewScoped beans were still OmniFaces CDI @ViewScoped, and I
>>> > experienced no issues. My app is not packaged as an EAR.
>>> >
>>> > today, i am using MyFaces 2.2 @ViewScoped beans even though I still have
>>> > OmniFAces 1.6.3 JAR/dependency (not using OmniFaces CDI @ViewScoped).
>>> >
>>> > For the first day, running MyFaces 2.2, I am quite pleased. No issues to
>>> > report, no exceptions in tomee/tomcat log files.
>>> >
>>> >
>>> >
>>> > On Wed, Jan 15, 2014 at 5:57 PM, José Luis Cetina <maxtorzito@gmail.com
>>> > >wrote:
>>> >
>>> > > I removed CODI and my app is package as ear. maybe i need to try tomee
>>> > > 1.6.1-snapshot
>>> > >
>>> > >
>>> > > 2014/1/15 Howard W. Smith, Jr. <smithh032772@gmail.com>
>>> > >
>>> > > > On Wed, Jan 15, 2014 at 4:40 PM, José Luis Cetina <
>>> > maxtorzito@gmail.com
>>> > > > >wrote:
>>> > > >
>>> > > > > I removed my faces 2.1.13 jars (api and imp) from tomee lib
and add
>>> > > > myfaces
>>> > > > > api and impl 2.2.0
>>> > > > >
>>> > > >
>>> > > > that's exactly what I did and I don't get the error.
>>> > > >
>>> > > > Jose, are you still using MyFaces CODI (1.5 or 1.6.x) and EAR,
too?
>>> > > >
>>> > >
>>> > >
>>> > >
>>> > > --
>>> > > -------------------------------------------------------------------
>>> > > *SCJA. José Luis Cetina*
>>> > > -------------------------------------------------------------------
>>> > >
>>> >
>>>
>>>
>>>
>>> --
>>> -------------------------------------------------------------------
>>> *José Luis Cetina*
>>> -------------------------------------------------------------------
>>>

Mime
View raw message