myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Meyer <patrick.me...@o2.pl>
Subject Re: ResourceHandler since version 2.1.6 works differently
Date Tue, 23 Apr 2013 13:05:21 GMT
Hi Myfaces Users!


The problem has been resolved. If your components are in nested folders(as in my case), since
myfaces 2.1.6 you have to use org.apache.myfaces.STRICT_JSF_2_ALLOW_SLASH_LIBRARY_NAME=true
context parameter. 
According to https://issues.apache.org/jira/browse/MYFACES-3631


Regards,
Patrick


Dnia 23 kwietnia 2013 11:57 Patrick Meyer <patrick.meyer@o2.pl> napisał(a):

> 
> Hi Myfaces Users!
> 
> I have a problem with ResourceHandler since version 2.1.6.  I’m getting following warning
and myComp:testComponent was not resolved/rendered. With Myfaces 2.1.5 the myComp:testComponent
was correctly resolved.
> 
> - Warning: The page /WEB-INF/includes/tab.xhtml declares namespace http://java.sun.com/jsf/composite/components/specComponent/custom
and uses the tag myComp:testComponent, but no TagLibrary associated to namespace. Please check
the namespace name and if it is correct, it is probably that your library .taglib.xml cannot
be found on the current classpath, or if you are referencing a composite component library
check your library folder match with the namespace and can be located by the installed ResourceHandler.
> 
> SETUP:
> 
> webapp
> |
> |-resources
> |    |-components
> |         |-specComponent
> |              |-custom
> |                  |-testComponent.xhtml
> |
> |
> |
> |-WEB-INF
> |    |-includes
> |        |-tab.xhtml
> |
> |-main.xhtml
> 
> 
> main.xhtml
> ---------------------------------------
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
> <html xmlns="http://www.w3.org/1999/xhtml"
>        xmlns:h="http://java.sun.com/jsf/html"
>        xmlns:ui="http://java.sun.com/jsf/facelets"
>        xmlns:f="http://java.sun.com/jsf/core">
> 
>        <ui:composition template="WEB-INF/templates/master.xhtml">
> 
>        <ui:define name="content">
>                     <ui:include src="WEB-INF/includes/tab.xhtml" />
>        </ui:define>
> 
> </ui:composition>
> 
> </html>
> 
> 
> tab.xhtml
> -------------------------------
> <div id="content-tab"
>        xmlns:ui="http://java.sun.com/jsf/facelets"
>        xmlns:h="http://java.sun.com/jsf/html"
>        xmlns:f="http://java.sun.com/jsf/core"
>        xmlns:myComp="http://java.sun.com/jsf/composite/components/specComponent/custom">
> 
>              <myComp:testComponent />
>        
> </div>
> 
> 
> Is it a bug, or I'm doing something wrong.
> 
> 
> Regards,
> Patrick 
> 
> 
> 

Mime
View raw message