myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kito Mann <kito.m...@virtua.com>
Subject [Extensions-Scripting] Java code changes not getting picked up
Date Fri, 31 Aug 2012 19:44:11 GMT
I'm trying to get MyFaces Extensions-Scripting running on RAD 8.0 with WAS
8.0 on Win 7 (no this isn't my choice of tools...) The goal is to use the
dynamic Java class loading to avoid the hideously long WAS publish times.
For the most part, everything is working fine now, and Ext-Scripting
notices when the class has changed and outputs the full list of classes
that are being loaded to the console. Unfortunately, the changes aren't
being picked up by the application. I've tried several different scenarios
(using a specific LOADER_PATH, the default WEB-INF/java path, changing the
publishing settings, turning Build Automatically on or off, etc.), but I
haven't had any luck. Perhaps WAS is doing something different at the
classloader level than Ext-Scripting expects? Any ideas?
___

Kito D. Mann | @kito99 | Author, JSF in Action
Virtua, Inc. | http://www.virtua.com | JSF/Java EE training and consulting
http://www.JSFCentral.com - JavaServer Faces FAQ, news, and info |
@jsfcentral
+1 203-404-4848 x246

* Listen to the latest headlines in the JSF and Java EE newscast: *
http://blogs.jsfcentral.com/JSFNewscast/*
* Sign up for the JSFCentral Newsletter: http://oi.vresp.com/?fid=ac048d0e17

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message