myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Reznick <vedm...@gmail.com>
Subject <h:outputScript is not being loaded when located in ui:include that is initially rendered="false"
Date Wed, 09 May 2012 15:11:05 GMT
Hi

I'm trying to load some heavy js file only after a user have clicked on
button

so basically when user loads the main page there is a hidden page inside
<ui:include

     <h:body>
        <h:form>
            <h:commandButton value="ClickMe" action="#{myBean.callme()}" >
                <f:ajax render="includeWrapper"></f:ajax>
            </h:commandButton>
            <h:panelGroup id="includeWrapper">
                wrapper
                <h:panelGroup rendered="#{myBean.show}">
                    <ui:include src="/page2.xhtml"></ui:include>
                </h:panelGroup>
            </h:panelGroup>
        </h:form>
    </h:body>


that hidden page got <h:outputScript that should be rendered when  user
will click on the commandButton


page2.xhtml looks like this

<ui:composition xmlns="http://www.w3.org/1999/xhtml" xmlns:ui="
http://java.sun.com/jsf/facelets"
    xmlns:h="http://java.sun.com/jsf/html" xmlns:f="
http://java.sun.com/jsf/core"
    xmlns:c="http://java.sun.com/jsp/jstl/core">


    #{myBean.show}
    <h:outputScript library="js" name="myscript.js"
rendered="#{myBean.show}"/>
    Woooow
</ui:composition>


and my callme looks like this

    public void callme(){
        show = !show;
        System.out.println("caaaaaaaaaaaal me\t"+show);
    }

This works perfectly in my mojarra sandbox , but for some reason it is not
being loaded in my Myfaces 2.0.11 application I even tried the latest 2.1.8
snapshot

Is there any web.xml configuration that I'm missing

Thanks ahead,


Daniel.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message