myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Georg Füchsle <giofy...@googlemail.com>
Subject Re: Recognize Browser-Version in JSF doesn’t work on WAS6.1
Date Fri, 06 Jan 2012 15:14:28 GMT
Hallo,


Now after some time I tried again on the same problem.

I acchieved to load my own JSF-Libraries. For this I followed this link:
http://www.denoo.info/2008/02/finally-jsf-12-and-facelets-on-websphere-61/
I only switched the class-loader of the EAR to PARENT_LAST.

But to use some facelet-functionality I had to change the
JSF-StateSaving from 'client' to 'server' (only on WAS6.1)

With my own JSF-Libs the browser-version was recognized well.

Thanks for all for your help.

Georg


2011/11/3 Georg Füchsle <giofyxle@googlemail.com>:
> Hi Toby,
>
> I gave up for today.
> No matter what I do, as soon as I switch the class loader of the webapp I get
> SRVE0201E: Das Servlet
> [javax.faces.webapp.FacesServlet] ist keine Servlet-Klasse.
> when starting the application.
>
> I did not mention that I use the sun implementation.
>
> On the weekend I will try to start with a small application from the
> scratch... maybe I find something out.
>
> Thanks for your help
>
> Georg

Mime
View raw message