myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Catherine Rocchio" <crocc...@commoninf.com>
Subject Trinidad 2.0 - Anyone have issues with SelectManyShuttle tag?
Date Fri, 08 Jul 2011 21:10:05 GMT
Hi there,

 

Consistently, when we try to use the selectManyShuttle instead of a
selectManyListbox - the Submit button on the page/form stops working - won't
do anything.

 

It isn't just the rendering on the page that does it (if you don't touch the
widget, it is fine.) - but the second you "touch" the widget in the form, it
causes the submit button to hang.  The widget itself works great - the
remove, move alls, etc.. all work great - but something crazy is going on
with now not being able to use the command button that does the save.

 

It is a simple simple page - and the code all works perfectly/functionality
all works perfectly when I pop the selectManyListbox into place instead.

 

Is there some debugging I can turn on to try to figure out more of what is
going on??  I've tried looking at the source for the page.. but wasn't able
to figure out what could be going on.

 

THANKS THANKS!

 

Catherine

 

<tr:selectManyShuttle label="Select Data Partners:" size="15" value =
"#{workplaneditorbean.selectedPartners}" id="selectdatapartners">

<f:selectItems value = "#{workplaneditorbean.dataPartnerList}" />

</tr:selectManyShuttle>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message