myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerhard <gerhard.petra...@gmail.com>
Subject Re: No saved view state could be found for the view identifier
Date Mon, 09 Aug 2010 17:29:31 GMT
@michael:
you can use a jsf page as welcome file - just remove the leading slash.

regards,
gerhard

http://www.irian.at

Your JSF powerhouse -
JSF Consulting, Development and
Courses in English and German

Professional Support for Apache MyFaces


2010/8/9 Michael Kurz <michi.kurz@gmx.at>

> Would be interesting if anyone else has encountered this problem so far?
>
> Am 09.08.2010 18:53, schrieb Michael Kurz:
>
>  This is a strange problem. I tried your example and it turned out that
>> the server gets confused if you use a JSF view as welcome file.
>>
>> Simply create an html file index.html with the following content and use
>> this as welcome file:
>>
>> <html>
>> <head>
>> <meta http-equiv="refresh" content="0; URL=index.xhtml">
>> </head>
>> </html>
>>
>> Should work.
>>
>> If you are interested, the real problem was that the path returned from
>> the servlet request was //index.xhtml and JSF can't find the state for
>> the view which is /index.xhtml. Strange, but I didn't dig further into
>> this issue.
>>
>> regards
>> Michael
>>
>> Am 09.08.2010 17:21, schrieb Roman:
>>
>>>
>>> Hi
>>>
>>> On Mon, 9 Aug 2010, Michael Kurz wrote:
>>>
>>>  Hi,
>>>>
>>>> I don't know if it solves the problem but an action method should
>>>> normally return a String value. Simply return null to stay on the same
>>>> page.
>>>>
>>>>
>>> I have fixed that, thanks. The same exception is still always thrown.
>>>
>>> Roman
>>>
>>>  regards
>>>> Michael
>>>>
>>>> Am 09.08.2010 13:28, schrieb Roman:
>>>>
>>>>>
>>>>>
>>>>> Hi.
>>>>> I have a very simple test application written using MyFaces 1.2.9 and
>>>>> RichFaces 3.3.3. And I get this exception
>>>>> javax.faces.application.ViewExpiredException - /xhtml/index.xhtmlNo
>>>>> saved view state could be found for the view identifier:
>>>>> /xhtml/index.xhtml
>>>>> every time I press the commandButton.
>>>>>
>>>>> I have attached all files web.xml, faces-config.xml, index.xhtml and
>>>>> Bean.java.
>>>>>
>>>>> Is there something wrong in the configuration? I really do not have any
>>>>> idea what is cousing this error.
>>>>>
>>>>> Thanks for any help.
>>>>> Roman
>>>>>
>>>>
>>>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message