myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Van <ionew...@gmail.com>
Subject Re: Myfaces Portlet Bridge error on deploy
Date Thu, 01 Apr 2010 09:20:27 GMT
Hello,

First , modify the web.xml

"<servlet>
<servlet-name>portlet-bridge-blank</servlet-name>
<display-name>portlet-bridge-blank Wrapper</display-name>
<description>Automated generated Portlet Wrapper</description>
<servlet-class>com.liferay.portal.kernel.servlet.PortletServlet</servlet-class>
<init-param>
<param-name>portlet-guid</param-name>
<param-value>portletBridgeBlank.portlet-bridge-blank</param-value>
</init-param>
<init-param>
<param-name>portlet-class</param-name>
<param-value>javax.portlet.faces.GenericFacesPortlet</param-value>
</init-param>
<init-param>
<param-name>portlet-name</param-name>
<param-value>portletBridgeBlank</param-value>
</init-param>
</servlet> "

and servet-mapping:

 <servlet-mapping>
<servlet-name>portlet-bridge-blank</servlet-name>
<url-pattern>/portlet-bridge-blank/*</url-pattern>
</servlet-mapping>


Second,  in portlet.xml
*delete* description tag

BTW: your error log too long, pls don't paste them all.


I downloaded
> http://www.apache.org/dyn/closer.cgi/myfaces/binaries/portlet-bridge
> -1.0.0-beta-2-example.tar.gz<http://www.apache.org/dyn/closer.cgi/myfaces/binaries/portlet-bridge-1.0.0-beta-2-example.tar.gzportlet-bridge-1.0.0-beta-2-example>
> portlet-bridge-1.0.0-beta-2-example<http://www.apache.org/dyn/closer.cgi/myfaces/binaries/portlet-bridge-1.0.0-beta-2-example.tar.gzportlet-bridge-1.0.0-beta-2-example>
I chose
> portlet-bridge-blank-1.0.0-
> beta-2.war file and :
>
> 1) I removed de "lang" atrribute for  description and display-name elements
> in portlet.xml ( liferay sent an error)
>
> 2) I added these simple three files in WEB-INF
>
> //////////////////////////                         liferay-portlet.xml
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message