myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Aranda <brunoara...@gmail.com>
Subject Re: Primefaces p:dataTable not decoding, seems to be a MyFaces 2 problem
Date Wed, 17 Mar 2010 16:50:10 GMT
Wonderful! I was too rusty for this one :)

Thanks!

Bruno

On 17 March 2010 16:44, Jakob Korherr <jakob.korherr@gmail.com> wrote:

> Found it!
>
> The problem is that Primefaces' PartialViewRoot keeps its own children list
> and the method on UIComponentBase (getFacetsAndChildren()) does not take
> getChildren() but _childrenList into account when creating the Iterator.
> This one was hard to find...
>
> I will create a JIRA issue for this and fix it asap.
>
> Regards,
> Jakob
>
> 2010/3/17 Matthias Wessendorf <matzew@apache.org>
>
> > On Wed, Mar 17, 2010 at 4:27 AM, Bruno Aranda <brunoaranda@gmail.com>
> > wrote:
> > > Hi,
> > >
> > > In my fancy little webapp I am using Primefaces dataTable in lazy mode
> > such
> > > as in this example[1], and I want to use it with MyFaces 2. However
> there
> > > seems to be a bug and the component decoding is not invoked, so if you
> > > navigate to another page of the table the row index does not change.
> > >
> > > It can be reproduced just getting the primefaces showcase examples:
> > >
> > > svn co
> > http://primefaces.googlecode.com/svn/examples/trunk/prime-showcase
> > >
> > > Then replacing the MyFaces 2 dependencies in the profile to the latest
> > (it
> > > does not work either with Myfaces 2.0.0-beta or beta2). And run the
> > showcase
> > > with:
> > >
> > > mvn jetty:run-exploded -Pmyfaces-2.0
> >
> > oh, that's not the default?
> > Pretty odd, especially since the stuff is from a committer ;-)
> >
> > @NotSerializableException: IMO it is ok to have that exception,
> > since the bean is in session and not implements the right contract
> > for passivation... (=> demo bug)
> >
> > -Matthias
> >
> > >
> > > If you modify slightly the dataTable example so it shows the first
> result
> > in
> > > one column (by modifying the TableBean class), you will see it is
> always
> > 0.
> > >
> > > A debugging session shows that the decode for dataTable renderer is
> never
> > > invoked. I am a bit rusty with all this, does any one have an idea what
> > may
> > > be happening or what could I look to pinpoint the problem?
> > >
> > > Thanks,
> > >
> > > Bruno
> > >
> > > [1] http://www.primefaces.org:8080/prime-showcase/ui/datatableLazy.jsf
> > >
> >
> >
> >
> > --
> > Matthias Wessendorf
> >
> > blog: http://matthiaswessendorf.wordpress.com/
> > sessions: http://www.slideshare.net/mwessendorf
> > twitter: http://twitter.com/mwessendorf
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message