myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Dagnino.Thie...@hydro.qc.ca>
Subject I'm having problems integrating myfaces 1.2.6 with SAP Java Server WebXMLParser
Date Wed, 09 Dec 2009 21:31:01 GMT
          Hi,

	 
	I'm having problems integrating myfaces 1.2.6 with SAP Java
Server (Java 1.5)
	 
	The problem , I found was in the code for
org.apache.myfaces.shared_impl.webapp.webxml.WebXmlParser parse()
method.
	 
	the parse method does the following 
	 
	****    
	InputSource is = createContextInputSource(null,
"/WEB-INF/web.xml");
	
	      if (is == null)
	      {
	        URL url = this._context.getResource("/WEB-INF/web.xml");
	        log.debug("No web-xml found at : " + ((url == null) ? "
null " : url.toString()));
	        return this._webXml;
	      }
	 
	      Document document = db.parse(is);
	 
	      Element webAppElem = document.getDocumentElement();
	      if ((webAppElem == null) ||
(!(webAppElem.getNodeName().equals("web-app"))))
	        throw new FacesException("No valid web-app root element
found!");
	*****
	 
	but the JDK 1.5 implementation is namespace aware so the return
of getNodeName is in our system ns1:web-app 
	 
	I think the implementation should do getLocalName() instead of
getNodeName ... 
	 
	Does anyone have a suggestion to how to get arround this... I'm
sure someone else has a system where the web.xml file has namespaces in
it ...
	 
	Thank you and sorry if this question is not posted at the right
place... if so please redirect me to the right list.
	 
	Thanks again.
	 
	
	Thierry Dagnino 
	 
	 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message