myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bart Kummel <b...@kummelweb.nl>
Subject Re: [Trinidad] Trinidad and Glassfish: resource servlet does not work
Date Tue, 29 Dec 2009 13:20:01 GMT
Hi Walter,

I never used 1.1, so I don't have experience with 1.1 to 1.2 migration.
However, I think the changes from 1.1 to 1.2 shouldn't have much impact. For
what I know, most are improvements that will only make your life easier. If
I were you, I'd try upgrading and see if the existing code runs without
changes. Good luck!

Regards,
Bart

2009/12/29 Walter Mourão <walter.mourao@gmail.com>

> Hi Bart,
> I will search a doc about migrating from 1.1 to 1.2. If you have some doc
> or info to make my path easier, please let me know.
>
> thanks,
>
>
> Walter Mourão
> http://waltermourao.com.br
> http://arcadian.com.br
> http://oriens.com.br
>
>
>
> 2009/12/29 Bart Kummel <bart@kummelweb.nl>
>
> Hi Walter,
>>
>> I do use Trinidad on Glassfish. I'm using Trinidad 1.2.x though. Why don't
>> you switch to 1.2.x?
>>
>> Best regards,
>> Bart
>>
>> 2009/12/29 Walter Mourão <walter.mourao@gmail.com>
>>
>> I would like to know if somebody is using Trinidad + Glassfish
>>> successfully...
>>>
>>>
>>>
>>> Walter Mourão
>>> http://waltermourao.com.br
>>> http://arcadian.com.br
>>> http://oriens.com.br
>>>
>>>
>>>
>>> 2009/12/24 Walter Mourão <walter.mourao@gmail.com>
>>>
>>> Hi Bart,
>>>> I'm already using this way.
>>>> my sun-web.xml :
>>>>
>>>> <?xml version="1.0" encoding="UTF-8"?>
>>>>> <!DOCTYPE sun-web-app PUBLIC "-//Sun Microsystems, Inc.//DTD
>>>>> Application Server 8.1 Servlet 2.4//EN" "
>>>>> http://www.sun.com/software/appserver/dtds/sun-web-app_2_4-1.dtd">
>>>>>
>>>>> <sun-web-app>
>>>>> <class-loader delegate="false"/>
>>>>> <property name="useMyFaces" value="true"/><!-- Glassfish V2
-->
>>>>> <property name="useBundledJsf" value="true"/><!-- Glassfish
V3 -->
>>>>> </sun-web-app>
>>>>>
>>>>
>>>> No luck yet.
>>>>
>>>>
>>>> Walter Mourão
>>>> http://waltermourao.com.br
>>>> http://arcadian.com.br
>>>> http://oriens.com.br
>>>>
>>>>
>>>>
>>>> On Wed, Dec 23, 2009 at 11:49 AM, Bart Kummel <bkummel@gmail.com>wrote:
>>>>
>>>>> Hi Walter,
>>>>>
>>>>> Do you have the <class-loader delegate="false"/> element in your
>>>>> sun-web.xml? Like this:
>>>>> <sun-web-app >
>>>>>  <class-loader delegate="false"/>
>>>>>  <property name="useMyFaces" value="true"/>
>>>>> </sun-web-app>
>>>>>
>>>>> There are several class loading problems, and this setting seems to
>>>>> solve
>>>>> some of them...
>>>>>
>>>>> Best regards,
>>>>> Bart
>>>>>
>>>>> 2009/12/22 Walter Mourão <walter.mourao@gmail.com>
>>>>>
>>>>> > Hi Matthias, thanks the attention.
>>>>> >
>>>>> > I just checked and I'm sure the resource servlet is executed. The
url
>>>>> is
>>>>> > null after "URL url = loader.getResource(resourcePath);" in:
>>>>> > ...
>>>>> >    ResourceLoader loader = _getResourceLoader(request);
>>>>> >    String resourcePath = getResourcePath(request);
>>>>> >    URL url = loader.getResource(resourcePath);
>>>>> >
>>>>> >    // Make sure the resource is available
>>>>> >    if (url == null)
>>>>> >    {
>>>>> >      response.sendError(HttpServletResponse.SC_NOT_FOUND);
>>>>> >      return;
>>>>> >    }
>>>>> > ...
>>>>> >
>>>>> > Some "not found" resources I saw during debug:
>>>>> > /adf/jsLibs/DebugCommon1_0_10.js
>>>>> >  /adf/styles/cache/default-desktop-lmwkb-ltr-gecko.css
>>>>> > /adf/images/t.gif
>>>>> >
>>>>> > Since the application is running fine in a standalone Tomcat, I
think
>>>>> the
>>>>> > problem is related with some classloader issue regarding Glassfish
X
>>>>> > Trinidad ...
>>>>> >
>>>>> > Hints ?
>>>>> > Should I open a Jira issue ? In Glassfish or Trinidad :-) ?
>>>>> >
>>>>> > Walter Mourão
>>>>> > http://waltermourao.com.br
>>>>> > http://arcadian.com.br
>>>>> > http://oriens.com.br
>>>>> >
>>>>> >
>>>>> >
>>>>> > On Mon, Dec 21, 2009 at 10:38 AM, Matthias Wessendorf <
>>>>> matzew@apache.org
>>>>> > >wrote:
>>>>> >
>>>>> > > did you check (w/ debugger) that the resource servlet is really
>>>>> executed
>>>>> > ?
>>>>> > > If not, that's likely some container specific issue
>>>>> > >
>>>>> > > -M
>>>>> > >
>>>>> > > 2009/12/21 Walter Mourão <walter.mourao@gmail.com>:
>>>>> > > > Hi folks,
>>>>> > > > I'm trying to make an existing Trinidad (1.0.10) application
to
>>>>> work in
>>>>> > > > Glassfish (2.1.1).
>>>>> > > > After creating the sun-web.xml with the property useMyFaces=true,
>>>>> the
>>>>> > > > application started to work, but the resources from Trinidad
>>>>> (css,
>>>>> > > > javascript) isn't going to the browser.
>>>>> > > > The urls inside the html source code are correct and it
looks
>>>>> like the
>>>>> > > > servlet isn't being executed.
>>>>> > > > I checked in Glassfish and the servlet is recognized (appears
as
>>>>> > > > "sub-component" of the web application).
>>>>> > > >
>>>>> > > > Any hints ?
>>>>> > > >
>>>>> > > > Thanks in advance,
>>>>> > > >
>>>>> > > > Walter Mourão
>>>>> > > > http://waltermourao.com.br
>>>>> > > > http://arcadian.com.br
>>>>> > > > http://oriens.com.br
>>>>> > > >
>>>>> > >
>>>>> > >
>>>>> > >
>>>>> > > --
>>>>> > > Matthias Wessendorf
>>>>> > >
>>>>> > > blog: http://matthiaswessendorf.wordpress.com/
>>>>> > > sessions: http://www.slideshare.net/mwessendorf
>>>>> > > twitter: http://twitter.com/mwessendorf
>>>>> > >
>>>>> >
>>>>>
>>>>
>>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message