myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Heinen <michael.hei...@recommind.com>
Subject RE: pages not rendered anymore after update from 1.1.6 to 1.2.8
Date Tue, 08 Dec 2009 16:24:07 GMT
Thanks Richard, I tried this finally with a simple page in this project.

TILES is the culprit.
My simple page is now rendered with tomahawk tags 
after I removed context param org.ajax4jsf.VIEW_HANDLERS=org.apache.myfaces.tomahawk.application.jsp.JspTilesViewHandlerImpl
from web.xml.

The content of <f:view> is NOT rendered at all as soon as I add the above context param
for tiles again.
Sample jsp:

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h"%>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f"%>
<%@ taglib uri="http://myfaces.apache.org/tomahawk" prefix="t"%>
<html><head></head><body>
hello
<f:view>world<h:outputText value="20"/><t:outputText value="09"/></</f:view>
</body></html>


Output: hello
The <f:view> tag is not processed at all with Tiles.

Does anybody know what to do with tiles and JSF 1.2 (myFaces 1.2.8, tomahawk12_1.1.9 and richfaces
3.3.2)?
Debugging all the frameworks together is really time consuming 

Michael


-----Original Message-----
From: Richard Yee [mailto:richard.k.yee@gmail.com] 
Sent: Dienstag, 8. Dezember 2009 16:09
To: MyFaces Discussion
Subject: Re: pages not rendered anymore after update from 1.1.6 to 1.2.8

Have you tried just having a page with a JSF outputText tag to see if
that works? (No tiles or Richfaces)

I would start from there and then add other tags to narrow down where
the problem is.

-R


Mime
View raw message