myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dj Apal [GR]" <dja...@gmail.com>
Subject Re: Trying to put my pages in subfolders (Absolute Beginner Talk)
Date Wed, 08 Jul 2009 20:14:33 GMT
OK just put ./ instead of / then (relative path)

2009/7/8 Marcelo Lotif <mlotifjava@gmail.com>

> I've already tried this, but it gives me a 404 error from tomcat
> saying that the resource is not available. The URL says
> "http://localhost:8080/register/ClientRegister.jsf" instead of
> "http://localhost:8080/appname/register/ClientRegister.jsf". This
> second way appears when I put the way I wrote first, which I presume
> is correct, but this also gives me the same 404 page.
>
> On Wed, Jul 8, 2009 at 4:40 PM, Dj Apal [GR]<djapal@gmail.com> wrote:
> > <h:outputLink value="/register/
> > ClientRegister.jsf" >link</h:outputLink>
> >
> > 2009/7/8 Marcelo Lotif <mlotifjava@gmail.com>
> >>
> >> Hi all,
> >>
> >> Fir. I'm new to MyFaces and I'm stating to build a new application.
> >> I'm using MyFaces + Facelets + RichFaces, and It's all already up and
> >> running on Eclipse, but I'm trying to put some of my pages inside a
> >> subfolder and I was not well succeeded. Here's an example of what I
> >> got:
> >>
> >>  - WebContent
> >>    - META-INF
> >>    - WEB-INF
> >>        - lib
> >>        - faces-config.xml
> >>        - web.xml
> >>    - ClientRegister.jspx
> >>    - Template.jspx
> >>    - index.jspx
> >>
> >> with a link structured like this:
> >> <h:outputLink value="ClientRegister.jsf" >link</h:outputLink>
> >>
> >> The above example is working. Here's what I'm trying to do:
> >>
> >>  - WebContent
> >>    - META-INF
> >>    - WEB-INF
> >>        - lib
> >>        - faces-config.xml
> >>        - web.xml
> >>    - register
> >>        - ClientRegister.jspx
> >>    - Template.jspx
> >>    - index.jspx
> >>
> >> with a link structured like this:
> >> <h:outputLink value="register/ClientRegister.jsf" >link</h:outputLink>
> >>
> >> And this is not working.
> >>
> >> I've already googled with no success.
> >>
> >> Can someone point me what am I doing wrong?
> >>
> >> --
> >> Marcelo Lotif
> >
> >
>
>
>
> --
> Marcelo Lotif
>

Mime
View raw message