myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <stephen.alan.conno...@gmail.com>
Subject Re: [Trinidad] Strange form submission issue
Date Tue, 07 Jul 2009 08:24:36 GMT
actually... the problem just moves to the other side of the link... i.e. the
page resulting from the s:button action needs to be displayed twice beofre
the submit works... with the tr:commandButton, you need to click the button
twice, but the page works first time!

2009/7/7 Stephen Connolly <stephen.alan.connolly@gmail.com>

> Hmmmm... if I replace the tr:commandButton with an s:button from seam, the
> problem goes away
>
> 2009/7/7 Stephen Connolly <stephen.alan.connolly@gmail.com>
>
> Hi,
>>
>> I have a web application using:
>>
>> Sun JSF RI (1.2 latest version)
>> Facelets (latest)
>> Trinidad 1.2.7
>> Tomahawk 1.1.8
>> Seam 2.0.1.GA
>> Some custom corporate components (... which requires the versions of the
>> above)
>>
>> I am seeing this strange issue.
>>
>> I have a form on the first page.
>>
>> <tr:form>
>>  <tr:commandButton action="#{somebean.doSomething}" .../>
>>  ...
>> </tr:form>
>>
>> The first time the page is displayed, the button works perfectly fine.
>>
>> Thereafter, any time the page is displayed, the button will not work
>> _the first time you click on it_. it will work perfectly fine the
>> second time that you click on it, however.
>>
>> My suspicion is that this is an issue with the rendering of the other
>> custom components on the page... but, as I am trying to create a
>> simple test application to show that this is the case I thought I'd
>> ask first to see if this is a known issue with Trinidad (since it's a
>> tr:commandButton that is not working within a tr:form)
>>
>> Anyone?
>>
>> -Stephen
>>
>
>

Mime
View raw message