myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Burghard Britzke <b...@charmides.in-berlin.de>
Subject Re: [Trinidad] charset
Date Tue, 30 Dec 2008 07:35:01 GMT
are you trying to render xml? you probably run into https://issues.apache.org/jira/browse/TRINIDAD-1139

  and https://issues.apache.org/jira/browse/TRINIDAD-818 . the  
javascript generated for xml rendered pages is not valid and does not  
work. you should consider to vote for them or better fix it. I wonder  
why so few users run into this issue. do they all render old fashioned  
html?

burghard.britzke

Am 30.12.2008 um 08:00 schrieb desik:

>
> I have a simple trinidad page, with no jsp:directive.page charset  
> specified:
>
> <?xml version="1.0" encoding="UTF-8" ?>
> <jsp:root xmlns:jsp="http://java.sun.com/JSP/Page" version="2.1"
>        xmlns:f="http://java.sun.com/jsf/core"
>        xmlns:h="http://java.sun.com/jsf/html"
>        xmlns:tr="http://myfaces.apache.org/trinidad">
>  <f:view>
>    <tr:document title="not working">
>      <tr:form>
>        <h:commandButton value="h: Click me"
> action="#{loginHandler.login}"/>
>        <tr:commandButton text="tr: Click me"
> action="#{loginHandler.login}"/>
>      </tr:form>
>    </tr:document>
>  </f:view>
> </jsp:root>
>
> Both buttons don't work. When I click them request is not sent to  
> server.
>
> Now, if I add:
>
> <jsp:directive.page contentType="text/html; charset=utf-8"/>
>
> at the beginning of the page, both buttons work properly.
> Environment: myfaces 1.2.5, trinidad 1.2.10, tomcat 6.0.18, windoze  
> vista,
> firefox 3.
> Do you thing this is a trinidad bug?
> -- 
> View this message in context: http://www.nabble.com/-Trinidad--charset-tp21213794p21213794.html
> Sent from the MyFaces - Users mailing list archive at Nabble.com.
>


Mime
View raw message