myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From laredotornado <laredotorn...@gmail.com>
Subject Re: How to get my filter to execute after MyFaces?
Date Wed, 29 Oct 2008 16:39:42 GMT

Thanks for your quick reply.  I discovered that when I put my filter-mapping
definition after that of the MyFaces filter, everything works fine.  So
although that doesn't attack the problem head-on, at least its a temporary
solution until I can figure out why putting the filter before the MyFaces
one causes problems.

 - Dave



Simon Kitching wrote:
> 
> laredotornado schrieb:
>> Hi,
>>
>> I'm using MyFaces 1.1.6 with Tomahawk 1.1.7 on WebLogic 9.2.2 (Solaris
>> 9). 
>> I'm noticing that when I add our company's servlet filter into our app
>>
>> <filter-mapping>
>>             <filter-name>SSOFilter</filter-name>
>>             <url-pattern>/*</url-pattern>
>> </filter-mapping>
>>
>> I get this error on visiting every page:
>>
>> ####<Oct 29, 2008 9:52:50 AM MDT> <Error> <HTTP> <rhonti>
>> <nps-supp-gui-ms-1> <[ACTIVE] ExecuteThread: '1' for queue:
>> 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <>
>> <1225295570358> <BEA-101020>
>> <[weblogic.servlet.internal.WebAppServletContext@1cebcf0 - appName:
>> 'nps_history_gui', name: 'nps_history_gui.war', context-path:
>> '/nps_history_gui'] Servlet failed with Exception
>> java.lang.IllegalStateException: ExtensionsFilter not correctly
>> configured.
>> JSF mapping missing. JSF pages not covered. Please see:
>> http://myfaces.apache.org/tomahawk/extensionsFilter.html
>> The error goes away if I comment out the filter agove.  However, I need
>> it
>> for my app to work properly so my question is, how can I get the MyFaces
>> filter to ignore our company's filter?   Web.xml is below.  Thanks, -
>> Dave
>>   
> 
> I suspect that your filter is not correctly invoking the filter chain.
> There is normally no problem adding filters that apply before the
> FacesServlet; I do it all the time.
> 
> Try putting a trivial ServletFilter in first; if that works then look at
> why it works but your SSO filter does not. If the trivial filter does
> not work (ie you still get this problem) then post your trivial filter
> code here..
> 
> Regards,
> Simon
> 
> -- 
> -- Emails in "mixed" posting style will be ignored
> -- (http://en.wikipedia.org/wiki/Posting_style)
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/How-to-get-my-filter-to-execute-after-MyFaces--tp20230587p20231021.html
Sent from the MyFaces - Users mailing list archive at Nabble.com.


Mime
View raw message