myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gvanma...@comcast.net (Gary VanMatre)
Subject Re: Partial submit is not working on Weblogic 10
Date Tue, 12 Aug 2008 14:28:01 GMT

 -------------- Original message ----------------------
From: "Matthias Wessendorf" <matzew@apache.org>
> Gary,
> 
> can you tell us the issue # from the RI for that?
> I want to check with myfaces.
> 


My best guess was 507 [1] but I'm really not sure, as the current (1.2_09) is 5 releases ahead.


[1] https://javaserverfaces.dev.java.net/issues/show_bug.cgi?id=507




> thx,
> Matthias
>

Gary
 
> On Mon, Aug 11, 2008 at 10:50 PM, Gary VanMatre <gvanmatre@comcast.net> wrote:
> >
> >  -------------- Original message ----------------------
> > From: "Matthias Wessendorf" <matzew@apache.org>
> >> On Mon, Sep 17, 2007 at 2:35 PM, mjdenham <mjdenham@gmail.com> wrote:
> >> >
> >> > I worked out that you need to enable the jstl 1.2 shared library in 
> Weblogic
> >> > 10 as it is not enabled by default.
> >> >
> >> > Now I get the following exception when redeploying the demo app:
> >> >
> >> > java.lang.IllegalStateException: strict servlet API: cannot call 
> getWriter()
> >> > after getOutputStream()
> >> >        at
> >> >
> >> 
> weblogic.servlet.internal.ServletResponseImpl.getWriter(ServletResponseImpl.java
> >> :297)
> >> >        at
> >> >
> >> 
> javax.servlet.ServletResponseWrapper.getWriter(ServletResponseWrapper.java:122)
> >> >        at
> >> >
> >> 
> org.apache.myfaces.application.jsp.JspViewHandlerImpl.renderView(JspViewHandlerI
> >> mpl.java:317)
> >> >        at
> >> >
> >> 
> javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:45
> >> )
> >> >        at
> >> >
> >> 
> org.apache.myfaces.trinidadinternal.application.ViewHandlerImpl.renderView(ViewH
> >> andlerImpl.java:175)
> >> >        Truncated. see log file for complete stacktrace
> >> >>
> >> >
> >> > Any ideas?
> >>
> >> This was fixed last week:
> >> https://issues.apache.org/jira/browse/TRINIDAD-1170
> >>
> >
> > Another issue that we have been seeing is that weblogic ships with JSF 1.2_03. 
> We've found that some large PPR request are truncated.  This bug was fix in JSF 
> 1.2_04.  You are better off including JSF 1.2_07 in your web project if you are 
> using the RI.
> >
> >
> >
> > Gary
> >
> >> >
> >> > Thanks
> >> >
> >> > Martin
> >> >
> >> >
> >> > Matthias Wessendorf-4 wrote:
> >> >>
> >> >> Hi,
> >> >>
> >> >> On 9/17/07, mjdenham <mjdenham@gmail.com> wrote:
> >> >>>
> >> >>> I downloaded trinidad-demo-1.2.2 and tried to run it on Weblogic
10.
> >> >>>
> >> >>> First of all I received
> >> >>>    java.lang.NoClassDefFoundError: javax/servlet/jsp/jstl/core/Config
> >> >>> so I added jstl.jar from jakarta-taglibs-standard-1.1.2.zip
> >> >>
> >> >> Trinidad 1.2.x is designed to work with JSF 1.2 / JavaEE 5.
> >> >> So, the JSTL version 1.2 is provided by the container. Doesn't
> >> >> Weblogic 10 do so ?
> >> >>
> >> >>
> >> >>> Then the demo appeared to run without problems but nothing happens
when I
> >> >>> click on any of the tabs on panelTabbed.jspx, navigationPane.jspx,
or
> >> >>> panelAccordion.jspx.  It seems none of the partial submits work.
> >> >>
> >> >> just tested this:
> >> >>
> >> >>
> >> 
> http://example.irian.at/trinidad-demo-20070917/faces/components/panelTabbed.jspx
> >> >>
> >> >> works for me.
> >> >>
> >> >> do you get any infos in the log?
> >> >> I recommend to use firebug, to see if there is a partial submit, via
> >> >> XHR (XmlHttpRequest object)
> >> >>
> >> >> -Matthias
> >> >>
> >> >>>
> >> >>> The last tab on navigationPane.jspx with the title 'Component Guide'
does
> >> >>> not do a partial submit and it works fine.  Also, interestingly,
if I
> >> >>> click
> >> >>> on a tab and then hit Page-refresh the tab changes.
> >> >>>
> >> >>> Please help.  Thanks.
> >> >>>
> >> >>> Martin
> >> >>> --
> >> >>> View this message in context:
> >> >>>
> >> 
> http://www.nabble.com/Partial-submit-is-not-working-on-Weblogic-10-tf4465921.htm
> >> l#a12733657
> >> >>> Sent from the MyFaces - Users mailing list archive at Nabble.com.
> >> >>>
> >> >>>
> >> >>
> >> >>
> >> >> --
> >> >> Matthias Wessendorf
> >> >>
> >> >> further stuff:
> >> >> blog: http://matthiaswessendorf.wordpress.com/
> >> >> mail: matzew-at-apache-dot-org
> >> >>
> >> >>
> >> >
> >> > --
> >> > View this message in context:
> >> 
> http://www.nabble.com/Partial-submit-is-not-working-on-Weblogic-10-tf4465921.htm
> >> l#a12734893
> >> > Sent from the MyFaces - Users mailing list archive at Nabble.com.
> >> >
> >> >
> >>
> >>
> >>
> >> --
> >> Matthias Wessendorf
> >>
> >> Need JSF and Web 2.0?
> >> http://code.google.com/p/facesgoodies
> >>
> >> further stuff:
> >> blog: http://matthiaswessendorf.wordpress.com/
> >> sessions: http://www.slideshare.net/mwessendorf
> >> mail: matzew-at-apache-dot-org
> >
> >
> 
> 
> 
> -- 
> Matthias Wessendorf
> 
> Need JSF and Web 2.0?
> http://code.google.com/p/facesgoodies
> 
> further stuff:
> blog: http://matthiaswessendorf.wordpress.com/
> sessions: http://www.slideshare.net/mwessendorf
> mail: matzew-at-apache-dot-org

Mime
View raw message