myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Robinson" <andrew.rw.robin...@gmail.com>
Subject Re: [Trinidad] action never called?!
Date Sat, 08 Mar 2008 16:03:53 GMT
Could you provide somd of the view code?
Are there any FacesMessages added to the FacesContext?

You can also debug the decoding of the view (CommandLinkRenderer may
be the name -- but I am not at my home computer to know)

Are you sure the POST is being made and making it to the server?

On Fri, Mar 7, 2008 at 7:46 PM, Stephen Friedrich <trinidad@eekboom.com> wrote:
> Hi, it's me again - the guy that always complains about incompatibilities
> and how he hates spending his nights on configuration and debugging ;-)
>
> Well...
>
> I just tried to upgrade from
>    Trinidad 1.0.6, MyFaces Core, Seam 1.2.1
> to
>    Trinidad 1.2.6, JSF RI 1.2, Seam 2.0.1
>
> After twiddling with xmls files and countless trial-and-errors I made some
> progress but finally seem to have hit a dead end:
>
> My login page displays fine, but the login button's action is never executed.
> No log output, no validation failures.
> Strange thing is that I can use an actionListener just fine.
>
> Most of my app then works fine (very few actions, mostly REST-style navigation).
>
> WT*?
>
> I tried debugging, but I can't even find the place where the action is supposed
> to be executed.
>
> UIXCommand.broadcast() looks like it should do it, but no such code in sight?
>
> Help, please!
>

Mime
View raw message