myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geetha Rodricks <geetha...@gmail.com>
Subject Re: Multiple requests for same image = very slow tree rendering
Date Fri, 15 Feb 2008 00:28:17 GMT

Hi

Did you get anywhere with this issue - I have found the same issue
We have a tree2 component with  lots of nodes.
To render the tree I get to see multiple gets of the same image which is
definitely slows the rendering of the tree.

Is there any way to avoid that ?

Thanks


Michel Goldstein wrote:
> 
> Hi,
> 
> I'm trying to track down a problem that seems to affect a few users of our
> application. We have a fairly large tree to display (about 1500 nodes)
> using
> Tomahawk's tree2 component (with client-side toggle). In most cases, it
> does
> take some time to load (as it has to load all nodes and each generates a
> quite large amount of Javascript/html), but in some cases it takes a LONG
> time to load (think 2 seconds to 2 minutes). When I look at the Tomcat
> access logs, I see things like:
> 
> [02/Jul/2007:11:42:49 -0800] "GET
> /ptd/faces/myFacesExtensionResource/org.apache.myfaces.renderkit.html.util.MyFacesResourceLoader/11819657/tree2.HtmlTreeRenderer/images/line-
> trunk.gif HTTP/1.1" 200 466
> [02/Jul/2007:11:43:00 -0800] "GET
> /ptd/faces/myFacesExtensionResource/org.apache.myfaces.renderkit.html.util.MyFacesResourceLoader/11819657/tree2.HtmlTreeRenderer/images/line-
> trunk.gif HTTP/1.1" 200 466
> [02/Jul/2007:11:43:00 -0800] "GET
> /ptd/faces/myFacesExtensionResource/org.apache.myfaces.renderkit.html.util.MyFacesResourceLoader/11819657/tree2.HtmlTreeRenderer/images/line-
> trunk.gif HTTP/1.1" 200 466
> [02/Jul/2007:11:43:00 -0800] "GET
> /ptd/faces/myFacesExtensionResource/org.apache.myfaces.renderkit.html.util.MyFacesResourceLoader/11819657/tree2.HtmlTreeRenderer/images/line-
> trunk.gif HTTP/1.1" 200 466
> [02/Jul/2007:11:43:00 -0800] "GET
> /ptd/faces/myFacesExtensionResource/org.apache.myfaces.renderkit.html.util.MyFacesResourceLoader/11819657/tree2.HtmlTreeRenderer/images/line-
> trunk.gif HTTP/1.1" 200 466
> ...
> 
> on and on. The only common thing among those users that I have seen so far
> is that they all use Internet Explorer 6 and seem always to have this
> issue.
> I tried to run IE6 on my computer with all the configurations they've told
> they had, and wasn't able to reproduce it. Does anybody know what metadata
> is sent by the ResourceLoader that could "fool" their IE into thinking
> that
> it needs to load this image over and over again?
> 
> As of versions, I'm using:
> myfaces/tomahawk: 1.1.5
> tomcat: 5.5.9
> 
> Thank you,
> Michel
> 
> 

-- 
View this message in context: http://www.nabble.com/Multiple-requests-for-same-image-%3D-very-slow-tree-rendering-tp11400185p15492608.html
Sent from the MyFaces - Users mailing list archive at Nabble.com.


Mime
View raw message