myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: trinidad-1.2.4-example not running in tomcat-6.0
Date Wed, 09 Jan 2008 16:23:30 GMT
ah...
(I think it was working... however)

The servlet-container for the JavaEE 5 env. should provide JSTL 1.2 and JSF 1.2.
Jetty doesn't. We ship (in the demo) the JSF, but not the JSTL.

IMO we shouldn't ship the JSF as well.

-M

On Jan 9, 2008 8:21 AM, Andrew Robinson <andrew.rw.robinson@gmail.com> wrote:
> No, I sent the email last night. I get a class not found exception on the
> 1.2 trunk with jetty6. The 1.0 trunk worked fine with jetty
>
> What I ran:
> Exception:
> java.lang.NoClassDefFoundError: javax/servlet/jsp/jstl/core
> /Config
>         at org.apache.myfaces.application.jsp.JspViewHandlerImpl.renderView
> (JspViewHandlerImpl.java:249)
>         at
> javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:45)
>         at
> org.apache.myfaces.trinidadinternal.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java
> :176)
>         at
> org.apache.myfaces.lifecycle.RenderResponseExecutor.execute(RenderResponseExecutor.java:41)
>         at
> org.apache.myfaces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:132)
>         at javax.faces.webapp.FacesServlet.service (FacesServlet.java:138)
> ...
>
> Command:
> (cd trinidad-examples/trinidad-demo/; mvn
> org.mortbay.jetty:maven-jetty6-plugin:run)
>
>
> Am I doing something wrong?
>
>
>
>
>
>  On Jan 9, 2008 9:15 AM, Matthias Wessendorf < matzew@apache.org> wrote:
> > it's not running in Jetty ?
> >
> > -M
> >
> >
> >
> >
> > On Jan 9, 2008 8:11 AM, Andrew Robinson <andrew.rw.robinson@gmail.com>
> wrote:
> > > Can you be more specific?
> > >
> > > I cannot get it to work through jdev as I get blank pages served. It
> also
> > > fails using jetty 6 due to a class not found exception. What is broken
> for
> > > you?
> > >
> > > -Andrew
> > >
> > >
> > >
> > >
> > > On Jan 8, 2008 9:01 PM, Ravindra Adireddy <adireddyravindra@gmail.com>
> > > wrote:
> > > > Hi all,
> > > >
> > > >          I am not abel to run trinidad-1.2.4-example in tomcat 6.0,
> > > > but i am abel to run trinidad-1.0.4-example in same server, can any
> > > > one please provide me the solution
> > > >
> > > >
> > > > --
> > > > Thanks and Regards
> > > > Ravindra Adireddy
> > > >
> > >
> > >
> >
> >
> >
> > --
> > Matthias Wessendorf
> >
> > further stuff:
> > blog: http://matthiaswessendorf.wordpress.com/
> > sessions: http://www.slideshare.net/mwessendorf
> > mail: matzew-at-apache-dot-org
> >
>
>



-- 
Matthias Wessendorf

further stuff:
blog: http://matthiaswessendorf.wordpress.com/
sessions: http://www.slideshare.net/mwessendorf
mail: matzew-at-apache-dot-org

Mime
View raw message