myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renzo Tomaselli <renzo.tomase...@tecnotp.it>
Subject Re: [Trinidad] using multiple triggers
Date Wed, 30 Jan 2008 11:35:14 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
This is nearly what I did:<br>
<br>
&nbsp;&nbsp;&nbsp; &lt;ui:component&gt;<br>
&nbsp; &nbsp;&nbsp;&nbsp; &nbsp; &lt;tr:panelGroupLayout id="anyValue"<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp; &nbsp; &lt;cx:multiHolder
triggers="a b c"/&gt;<br>
&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp; &nbsp; ...<br>
<br>
where subcomponent multiholder is:<br>
<br>
&nbsp;&nbsp;&nbsp; &lt;ui:component&gt;<br>
&nbsp;&nbsp; &nbsp;&nbsp; &nbsp; &lt;tr:panelGroupLayout&nbsp;
partialTriggers="#{triggers}"&gt;<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; ...<br>
<br>
but it doesn't work, array identity is lost after going through EL
resolution.<br>
<br>
-- Renzo<br>
<br>
Matthias Wessendorf wrote:
<blockquote
 cite="mid:71235db40801300323m10d98400of118eff3908035a3@mail.gmail.com"
 type="cite">
  <pre wrap="">or a #{stringThatHasMyTriggers},
where the String is:
String triggers = "comp1 comp2 comp3";

-M

On Jan 30, 2008 12:17 PM, Renzo Tomaselli <a class="moz-txt-link-rfc2396E" href="mailto:renzo.tomaselli@tecnotp.it">&lt;renzo.tomaselli@tecnotp.it&gt;</a>
wrote:
  </pre>
  <blockquote type="cite">
    <pre wrap=""> Matthias,
 in this case I had some names forced by outer components - which included
the current one - because they needed to know them for own partial
triggering.
 Nevertheless your suggestion doesn't work either (just tried), same error.
I feel that using EL for partial triggers fails, since the resolved value
turns out to be a string, while a string[] is expected.

 -- Renzo


 Matthias Wessendorf wrote:
 Hi

On Jan 28, 2008 12:54 PM, Renzo Tomaselli <a class="moz-txt-link-rfc2396E" href="mailto:renzo.tomaselli@tecnotp.it">&lt;renzo.tomaselli@tecnotp.it&gt;</a>
wrote:


 Hi, while using multiple triggers where a few names are achieved from
EL, I get an exception from ELSupport.coerceToType(obj, type).
E.g. while:

 partialTriggers="multiSelect multiAdd multiRemove multiUpdate"

works fine,

 partialTriggers="multiSelect #{multiAdd} multiRemove #{multiUpdate}"

does not work (having set multiAdd="multiAdd" in the component including
the current one.
In coerceToType call, I see obj="multiSelect multiAdd multiRemove
multiUpdate", and type=java.lang.String[].
While it would be easy to patch ELSupport to split the incoming string
so that matching succeeds - I wonder if I'm doing anything else wrong.

 why not doing this:
partialTriggers="#{stringArrayThatContainsAllMyTriggers}" instead of
"multi el" ?

-M



 -- Renzo








    </pre>
  </blockquote>
  <pre wrap=""><!---->


  </pre>
</blockquote>
</body>
</html>

Mime
View raw message