myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damon Weyant <DWey...@nesl.com>
Subject RE: MyFaces 1.1 not working on Websphere 5.1.1.15 with Classloader set to PARENT_LAST
Date Thu, 31 Jan 2008 18:22:13 GMT
I've had MyFaces application running on WAS v5.1.x before (we're currently running them in
WAS v6.1.x), I know one thing we did was set the WAR classloader policy from "Module" to "Application"
so maybe that might do the trick for you as well.  Hope this helps...

- Damon



-----Original Message-----
From: mchandir [mailto:mchandir@cya.com]
Sent: Wednesday, January 30, 2008 4:20 PM
To: users@myfaces.apache.org
Subject: MyFaces 1.1 not working on Websphere 5.1.1.15 with Classloader set to PARENT_LAST


I am trying to deploy a simple MyFaces application on Websphere App Server
5.1.1.15 and having trouble invoking the index page. I am using MyFaces
1.1.5 and tomahawk 1.1.6. I also went through this link http://wiki.apache.org/myfaces/Websphere_Installation
and still not working.
I want my Classloader mode to be PARENT_LAST for both application and Web Module as my application
needs it. This works fine on Websphere 6.0.2. I was able to successfully deploy the application
to WAS 5.1.1.15 with one additional jar file (jsp-api.jar) which is not part of WAS 6.0.2
deployment.
Has anyone successfully deployed MyFaces 1.1 on Websphere 5.1.x? if so do i need any additonal
jar file. Right now i have

commons-beanutils-1.7.0.jar
commons-codec-1.3.jar
commons-collections-3.1.jar
commons-digester-1.6.jar
commons-lang-2.1.jar
commons-fileupload-1.0.jar
commons-validator.jar
jsp-api.jar
jstl-1.0.jar
myfaces-api-1.1.5.jar
myfaces-impl-1.1.5.jar
standard-1.0.jar
tomahawk-1.1.3.jar

The problem i have is when i hit my index page url:
http://localhost:9080/myproj/index.faces i get a blank page and there is no error message
in the logs :-( I have no clue what is happening. But if i change the Web Module class loader
to PARENT_FIRST it is working fine, but i don't need that.

Any help will be useful as im stuck at this point. thanks in advance


--
View this message in context: http://www.nabble.com/MyFaces-1.1-not-working-on-Websphere-5.1.1.15-with-Classloader-set-to-PARENT_LAST-tp15192182p15192182.html
Sent from the MyFaces - Users mailing list archive at Nabble.com.




Mime
View raw message