myfaces-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karr, David" <david.k...@wamu.net>
Subject RE: Initial try of moving RichFaces app from WebLogic 9.2.2 to Tomcat 5.5 with MyFaces
Date Tue, 22 Jan 2008 03:54:41 GMT
> -----Original Message-----
> From: mwessendorf@gmail.com [mailto:mwessendorf@gmail.com] On 
> Behalf Of Matthias Wessendorf
> Sent: Monday, January 21, 2008 4:56 PM
> To: MyFaces Discussion
> Subject: Re: Initial try of moving RichFaces app from 
> WebLogic 9.2.2 to Tomcat 5.5 with MyFaces
> 
> On Jan 21, 2008 4:43 PM, Karr, David <david.karr@wamu.net> wrote:
> > I have a simple app using the default JSF 1.1 implementation in 
> > WebLogic 9.2.2, which also uses RichFaces 3.1.3.  It works 
> at this point.
> >
> > I installed Tomcat 5.5.25.  I copied all the jars from the MyFaces 
> > 1.1.5 lib directory to the "/shared/lib" directory of Tomcat.
> >
> > I copied the myfaces-example-simple-1.1.6 app to the 
> webapps dir.  I 
> > started up Tomcat and tested this app, and it appeared to be ok.
> 
> do you now have the 1.1.6 myfaces-libs in that 
> example/WEB-INF/lib folder as well ?

The myfaces-example-simple-1.1.6 app did have the myfaces jars in
WEB-INF/lib, but it was version 1.1.5 (curiously, the latest GA release
was 1.1.5, but the example apps are version 1.1.6).

So, I've now tried removing the jars I put into shared/lib and put them
into WEB-INF/lib instead.  What I now see is the following:

java.lang.NoClassDefFoundError: javax/servlet/jsp/SkipPageException
	org.apache.jsp.index_jsp._jspService(index_jsp.java:48)
	
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:98)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.ja
va:331)

So, this missing class was added in Servlet 2.4.  Tomcat 5.5.25 is a
Servlet 2.4 container, so why is this failing?

Mime
View raw message